summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-11 08:27:57 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-11 08:27:57 +0000
commit8e2b9aca5d1c20234888cba9781ce31893992787 (patch)
tree90b662f7fb4eceea0f86719497b51438f7e32a26 /gnome-extra
parentVersion bump. Removed old (diff)
downloadgentoo-2-8e2b9aca5d1c20234888cba9781ce31893992787.tar.gz
gentoo-2-8e2b9aca5d1c20234888cba9781ce31893992787.tar.bz2
gentoo-2-8e2b9aca5d1c20234888cba9781ce31893992787.zip
Port cinnamon-settings to new timedated dbus API (bug #434494, thanks to Antoine Lemoine).
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon/ChangeLog10
-rw-r--r--gnome-extra/cinnamon/cinnamon-1.4_p1-r1.ebuild248
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.4-UP1-spin-buttons.patch66
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.4-UP1-timedated.patch157
4 files changed, 480 insertions, 1 deletions
diff --git a/gnome-extra/cinnamon/ChangeLog b/gnome-extra/cinnamon/ChangeLog
index 3a9f5ad8eb31..a4bf3eb72ef3 100644
--- a/gnome-extra/cinnamon/ChangeLog
+++ b/gnome-extra/cinnamon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/cinnamon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/ChangeLog,v 1.15 2012/09/09 00:36:03 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/ChangeLog,v 1.16 2012/09/11 08:27:57 tetromino Exp $
+
+*cinnamon-1.4_p1-r1 (11 Sep 2012)
+
+ 11 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +cinnamon-1.4_p1-r1.ebuild, +files/cinnamon-1.4-UP1-spin-buttons.patch,
+ +files/cinnamon-1.4-UP1-timedated.patch:
+ Port cinnamon-settings to new timedated dbus API (bug #434494, thanks to
+ Antoine Lemoine).
09 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
-files/cinnamon-1.1.3-extensionjs_path.patch,
diff --git a/gnome-extra/cinnamon/cinnamon-1.4_p1-r1.ebuild b/gnome-extra/cinnamon/cinnamon-1.4_p1-r1.ebuild
new file mode 100644
index 000000000000..643f124b2632
--- /dev/null
+++ b/gnome-extra/cinnamon/cinnamon-1.4_p1-r1.ebuild
@@ -0,0 +1,248 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/cinnamon-1.4_p1-r1.ebuild,v 1.1 2012/09/11 08:27:57 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="xml"
+
+inherit autotools eutils gnome2 multilib pax-utils python
+
+DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+
+MY_PV="${PV/_p/-UP}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/linuxmint/Cinnamon/tarball/${MY_PV} -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+bluetooth +networkmanager"
+KEYWORDS="~amd64 ~x86"
+
+# gnome-desktop-2.91.2 is needed due to header changes, db82a33 in gnome-desktop
+# latest gsettings-desktop-schemas is needed due to commit 602fa1c6
+# latest g-c-c is needed due to https://bugs.gentoo.org/show_bug.cgi?id=360057
+# libXfixes-5.0 needed for pointer barriers
+# gnome-menus-3.2.0.1-r1 needed for new 10-xdg-menu-gnome
+COMMON_DEPEND=">=dev-libs/glib-2.29.10:2
+ >=dev-libs/gjs-1.29.18
+ >=dev-libs/gobject-introspection-0.10.1
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.0.0:3[introspection]
+ >=media-libs/clutter-1.7.5:1.0[introspection]
+ app-misc/ca-certificates
+ >=dev-libs/folks-0.5.2
+ >=dev-libs/json-glib-0.13.2
+ >=gnome-base/gnome-desktop-2.91.2:3[introspection]
+ >=gnome-base/gsettings-desktop-schemas-2.91.91
+ >=gnome-extra/evolution-data-server-2.91.6
+ >=media-libs/gstreamer-0.10.16:0.10
+ >=media-libs/gst-plugins-base-0.10.16:0.10
+ >=net-im/telepathy-logger-0.2.4[introspection]
+ net-libs/libsoup:2.4[introspection]
+ >=net-libs/telepathy-glib-0.15.5[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ >=x11-wm/muffin-1.0.2[introspection]
+
+ dev-libs/dbus-glib
+ dev-libs/libxml2:2
+ x11-libs/pango[introspection]
+ >=dev-libs/libcroco-0.6.2:0.6
+
+ gnome-base/gconf:2[introspection]
+ >=gnome-base/gnome-menus-3.2.0.1-r1:3[introspection]
+ gnome-base/librsvg
+ media-libs/libcanberra
+ media-sound/pulseaudio
+
+ >=x11-libs/startup-notification-0.11
+ x11-libs/libX11
+ >=x11-libs/libXfixes-5.0
+ x11-apps/mesa-progs
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.1.0[introspection] )
+ networkmanager? (
+ gnome-base/libgnome-keyring
+ >=net-misc/networkmanager-0.8.999[introspection] )"
+# Runtime-only deps are probably incomplete and approximate.
+# Each block:
+# 2. Introspection stuff + dconf needed via imports.gi.*
+# 3. gnome-session is needed for gnome-session-quit
+# 4. Control shell settings
+# 5. accountsservice is needed for GdmUserManager (0.6.14 needed for fast
+# user switching with gdm-3.1.x)
+# 6. caribou needed for on-screen keyboard
+# 7. xdg-utils needed for xdg-open, used by extension tool
+# 8. gconf-python needed for cinnamon-settings
+# 9. gnome-icon-theme-symbolic needed for various icons
+# 10. pygtk and gnome-menus:0 needed for menu editor
+# 11. timedated or DateTimeMechanism implementation for cinnamon-settings
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/dconf-0.4.1
+ >=gnome-base/libgnomekbd-2.91.4[introspection]
+ sys-power/upower[introspection]
+
+ >=gnome-base/gnome-session-3.2.1-r1
+
+ >=gnome-base/gnome-settings-daemon-2.91
+ >=gnome-base/gnome-control-center-2.91.92-r1
+
+ >=sys-apps/accountsservice-0.6.14[introspection]
+
+ >=app-accessibility/caribou-0.3
+
+ x11-misc/xdg-utils
+
+ dev-python/dbus-python
+ dev-python/gconf-python:2
+
+ x11-themes/gnome-icon-theme-symbolic
+
+ dev-python/pygtk
+ gnome-base/gnome-menus:0[python]
+
+ || (
+ app-admin/openrc-settingsd
+ >=sys-apps/systemd-30
+ <gnome-base/gnome-settings-daemon-3.3.5 )
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data )"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ !!=dev-lang/spidermonkey-1.8.2*"
+# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
+# https://bugs.gentoo.org/show_bug.cgi?id=360413
+
+S="${WORKDIR}/linuxmint-Cinnamon-af1653f"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+ # Don't error out on warnings
+ G2CONF="${G2CONF}
+ --enable-compile-warnings=maximum
+ --disable-schemas-compile
+ --disable-jhbuild-wrapper-script
+ $(use_with bluetooth)
+ $(use_enable networkmanager)
+ --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
+ BROWSER_PLUGIN_DIR=${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Fix automagic gnome-bluetooth dep, bug #398145
+ epatch "${FILESDIR}/${PN}-1.1.3-automagic-gnome-bluetooth.patch"
+
+ # Make networkmanager optional, bug #398593
+ epatch "${FILESDIR}/${PN}-1.3.1-optional-networkmanager.patch"
+
+ # Fix building with gnome-bluetooth-3.4
+ epatch "${FILESDIR}/${MY_P}-gnome-bluetooth-3.4-"{1,2}.patch
+
+ # cinnamon-settings spin button fix, in UP2
+ epatch "${FILESDIR}/${MY_P}-spin-buttons.patch"
+
+ # https://github.com/linuxmint/Cinnamon/issues/515, bug #434494
+ epatch "${FILESDIR}/${MY_P}-timedated.patch"
+
+ # Gentoo uses /usr/libexec
+ sed -e "s:/usr/lib/gnome-session/gnome-session-check-accelerated:${EPREFIX}/usr/libexec/gnome-session-check-accelerated:" \
+ -i "files/usr/share/gnome-session/sessions/cinnamon.session" || die "sed 1 failed"
+
+ # Gentoo uses /usr/$(get_libdir), not /usr/lib even for python
+ sed -e "s:/usr/lib/:/usr/$(get_libdir)/:" \
+ -e 's:"/usr/lib":"/usr/'"$(get_libdir)"'":' \
+ -i files/usr/bin/cinnamon-menu-editor \
+ -i files/usr/bin/cinnamon-settings \
+ -i files/usr/lib/cinnamon-menu-editor/Alacarte/config.py \
+ -i files/usr/lib/cinnamon-settings/cinnamon-settings.py \
+ -i files/generate_desktop_files || die "sed 2 failed"
+ if [[ "$(get_libdir)" != lib ]]; then
+ mv files/usr/lib "files/usr/$(get_libdir)" || die "mv failed"
+ fi
+
+ if ! use bluetooth; then
+ rm -rv files/usr/share/cinnamon/applets/bluetooth@cinnamon.org || die
+ fi
+
+ if ! use networkmanager; then
+ rm -rv files/usr/share/cinnamon/applets/network@cinnamon.org || die
+ fi
+
+ eautoreconf
+ gnome2_src_prepare
+
+ # Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
+ # Note: sed Makefile.in because it is generated from several Makefile.ams
+ sed -e 's/-DG_DISABLE_DEPRECATED//g' \
+ -i src/Makefile.in browser-plugin/Makefile.in || die "sed 3 failed"
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs 2 "${ED}usr/bin/cinnamon-extension-tool" \
+ "${ED}usr/bin/cinnamon-menu-editor" \
+ "${ED}usr/bin/cinnamon-settings" \
+ "${ED}usr/$(get_libdir)/cinnamon-settings/cinnamon-settings.py"
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ pax-mark mr "${ED}usr/bin/cinnamon"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize "/usr/$(get_libdir)/"cinnamon-{menu-editor,settings}
+
+ if ! has_version '>=media-libs/gst-plugins-good-0.10.23' || \
+ ! has_version 'media-plugins/gst-plugins-vp8'; then
+ ewarn "To make use of Cinnamon's built-in screen recording utility,"
+ ewarn "you need to either install >=media-libs/gst-plugins-good-0.10.23"
+ ewarn "and media-plugins/gst-plugins-vp8, or use dconf-editor to change"
+ ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version ">=x11-base/xorg-server-1.11"; then
+ ewarn "If you use multiple screens, it is highly recommended that you"
+ ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
+ ewarn "pointer barriers which will make it easier to use hot corners."
+ fi
+
+ if has_version "<x11-drivers/ati-drivers-12"; then
+ ewarn "Cinnamon has been reported to show graphical corruption under"
+ ewarn "x11-drivers/ati-drivers-11.*; you may want to use GNOME in"
+ ewarn "fallback mode, or switch to open-source drivers."
+ fi
+
+ if has_version "media-libs/mesa[video_cards_radeon]"; then
+ elog "Cinnamon is unstable under classic-mode r300/r600 mesa drivers."
+ elog "Make sure that gallium architecture for r300 and r600 drivers is"
+ elog "selected using 'eselect mesa'."
+ if ! has_version "media-libs/mesa[gallium]"; then
+ ewarn "You will need to emerge media-libs/mesa with USE=gallium."
+ fi
+ fi
+
+ if has_version "media-libs/mesa[video_cards_intel]"; then
+ elog "Cinnamon is unstable under gallium-mode i915/i965 mesa drivers."
+ elog "Make sure that classic architecture for i915 and i965 drivers is"
+ elog "selected using 'eselect mesa'."
+ if ! has_version "media-libs/mesa[classic]"; then
+ ewarn "You will need to emerge media-libs/mesa with USE=classic."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "/usr/$(get_libdir)/"cinnamon-{menu-editor,settings}
+}
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.4-UP1-spin-buttons.patch b/gnome-extra/cinnamon/files/cinnamon-1.4-UP1-spin-buttons.patch
new file mode 100644
index 000000000000..321bfbbd9581
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.4-UP1-spin-buttons.patch
@@ -0,0 +1,66 @@
+From 2a099e8be78db1c7fd0617daf54190ba65b84619 Mon Sep 17 00:00:00 2001
+From: Clement Lefebvre <clement.lefebvre@linuxmint.com>
+Date: Fri, 18 May 2012 18:33:14 +0100
+Subject: [PATCH] Fix a regression in GTK3's SpinButtons (non-editable now
+ means non-changeable at all now.. eventually we'll need to
+ port Cinnamon-settings to GTK2)
+
+---
+ debian/changelog | 6 ++++++
+ files/usr/lib/cinnamon-settings/cinnamon-settings.py | 12 ++++++------
+ 2 files changed, 12 insertions(+), 6 deletions(-)
+
+diff --git a/debian/changelog b/debian/changelog
+index 726780c..5914cd4 100644
+--- a/debian/changelog
++++ b/debian/changelog
+@@ -1,3 +1,9 @@
++cinnamon (1.4-UP1) maya; urgency=low
++
++ * 1.4 UP1
++
++ -- Clement Lefebvre <root@linuxmint.com> Sun, 13 May 2012 23:43:22 +0100
++
+ cinnamon (1.4.0) lisa; urgency=low
+
+ * New Cinnamon release
+diff --git a/files/usr/lib/cinnamon-settings/cinnamon-settings.py b/files/usr/lib/cinnamon-settings/cinnamon-settings.py
+index 7310ec9..fa1e212 100755
+--- a/files/usr/lib/cinnamon-settings/cinnamon-settings.py
++++ b/files/usr/lib/cinnamon-settings/cinnamon-settings.py
+@@ -537,7 +537,7 @@ class GSettingsSpinButton(Gtk.HBox):
+
+ self.content_widget.set_range(min, max)
+ self.content_widget.set_increments(step, page)
+- self.content_widget.set_editable(False)
++ #self.content_widget.set_editable(False)
+
+ self.settings = Gio.Settings.new(schema)
+ self.content_widget.set_value(self.settings.get_int(self.key))
+@@ -687,7 +687,7 @@ class GSettingsRangeSpin(Gtk.HBox):
+
+ self.content_widget.set_range(_min, _max)
+ self.content_widget.set_increments(_increment, _increment)
+- self.content_widget.set_editable(False)
++ #self.content_widget.set_editable(False)
+ self.content_widget.set_digits(1)
+ self.content_widget.set_value(self.settings.get_double(self.key))
+
+@@ -862,10 +862,10 @@ class ChangeTimeWidget(Gtk.HBox):
+ self.minSpin.configure(minAdj, 0.5, 0)
+ self.yearSpin.configure(yearAdj, 0.5, 0)
+ self.daySpin.configure(dayAdj, 0.5, 0)
+- self.hourSpin.set_editable(False)
+- self.minSpin.set_editable(False)
+- self.yearSpin.set_editable(False)
+- self.daySpin.set_editable(False)
++ #self.hourSpin.set_editable(False)
++ #self.minSpin.set_editable(False)
++ #self.yearSpin.set_editable(False)
++ #self.daySpin.set_editable(False)
+
+ self.update_time()
+ GObject.timeout_add(1000, self.update_time)
+--
+1.7.12
+
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.4-UP1-timedated.patch b/gnome-extra/cinnamon/files/cinnamon-1.4-UP1-timedated.patch
new file mode 100644
index 000000000000..e26080a8d0ce
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.4-UP1-timedated.patch
@@ -0,0 +1,157 @@
+From 4c9d4bddcbec9cf0e4cd866f70a498f321880693 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 11 Sep 2012 02:50:34 -0400
+Subject: [PATCH] Add a wrapper to switch between timedated and g-s-d's
+ DateTimeMechanism
+
+Upstream gnome-settings-daemon-3.4 and higher no longer implements
+org.gnome.SettingsDaemon.DateTimeMechanism. In some distros (e.g.
+Debian) this change had been reverted, and the old interface for now
+remains available. Other distros agree with the upstream decision and
+have switched to the new timedated interface as implemented by systemd
+and openrc-settingsd.
+
+This patch adds a simple wrapper around the two interfaces, allowing
+cinnamon-settings to support both. If the timedated interface is not
+available, the traditional g-s-d DateTimeMechanism is used.
+
+Fixes https://github.com/linuxmint/Cinnamon/issues/515
+---
+ .../usr/lib/cinnamon-settings/cinnamon-settings.py | 72 +++++++++++++++++++---
+ 1 file changed, 62 insertions(+), 10 deletions(-)
+
+diff --git a/files/usr/lib/cinnamon-settings/cinnamon-settings.py b/files/usr/lib/cinnamon-settings/cinnamon-settings.py
+index fa1e212..fbcfef2 100755
+--- a/files/usr/lib/cinnamon-settings/cinnamon-settings.py
++++ b/files/usr/lib/cinnamon-settings/cinnamon-settings.py
+@@ -28,7 +28,51 @@ gettext.install("cinnamon", "/usr/share/cinnamon/locale")
+ menuName = _("Desktop Settings")
+ menuGenericName = _("Desktop Configuration Tool")
+ menuComment = _("Fine-tune desktop settings")
+-
++
++# wrapper for timedated or gnome-settings-daemon's DateTimeMechanism
++class DateTimeWrapper:
++ def __init__(self):
++ try:
++ proxy = dbus.SystemBus().get_object("org.freedesktop.timedate1", "/org/freedesktop/timedate1")
++ self.dbus_iface = dbus.Interface(proxy, dbus_interface="org.freedesktop.timedate1")
++ self.properties_iface = dbus.Interface(proxy, dbus_interface=dbus.PROPERTIES_IFACE)
++ self.timedated = True
++ except dbus.exceptions.DBusException:
++ proxy = dbus.SystemBus().get_object("org.gnome.SettingsDaemon.DateTimeMechanism", "/")
++ self.dbus_iface = dbus.Interface(proxy, dbus_interface="org.gnome.SettingsDaemon.DateTimeMechanism")
++ self.timedated = False
++
++ def set_time(self, seconds_since_epoch):
++ if self.timedated:
++ # timedated expects microseconds
++ return self.dbus_iface.SetTime(seconds_since_epoch * 1000000, False, True)
++ else:
++ return self.dbus_iface.SetTime(seconds_since_epoch)
++
++ def get_timezone(self):
++ if self.timedated:
++ return self.properties_iface.Get("org.freedesktop.timedate1", "Timezone")
++ else:
++ return self.dbus_iface.GetTimezone()
++
++ def set_timezone(self, tz):
++ if self.timedated:
++ return self.dbus_iface.SetTimezone(tz, True)
++ else:
++ return self.dbus_iface.SetTimezone(tz)
++
++ def get_using_ntp(self):
++ if self.timedated:
++ return self.properties_iface.Get("org.freedesktop.timedate1", "NTP")
++ else:
++ return self.dbus_iface.GetUsingNtp()
++
++ def set_using_ntp(self, usingNtp):
++ if self.timedated:
++ return self.dbus_iface.SetNTP(usingNtp, True)
++ else:
++ return self.dbus_iface.SetUsingNtp(usingNtp)
++
+ class SidePage:
+ def __init__(self, name, icon, content_box):
+ self.name = name
+@@ -521,7 +565,17 @@ class DBusCheckButton(Gtk.CheckButton):
+
+ def on_my_value_changed(self, widget):
+ getattr(self.dbus_iface, self.dbus_set_method)(self.get_active())
+-
++
++class NtpCheckButton(Gtk.CheckButton):
++ def __init__(self, label):
++ super(NtpCheckButton, self).__init__(label)
++ self.date_time_wrapper = DateTimeWrapper()
++ self.set_active(self.date_time_wrapper.get_using_ntp())
++ self.connect('toggled', self.on_my_value_changed)
++
++ def on_my_value_changed(self, widget):
++ self.date_time_wrapper.set_using_ntp(self.get_active())
++
+ class GSettingsSpinButton(Gtk.HBox):
+ def __init__(self, label, schema, key, min, max, step, page, units):
+ self.key = key
+@@ -742,8 +796,7 @@ class TimeZoneSelectorWidget(Gtk.HBox):
+ def __init__(self):
+ super(TimeZoneSelectorWidget, self).__init__()
+
+- proxy = dbus.SystemBus().get_object("org.gnome.SettingsDaemon.DateTimeMechanism", "/")
+- self.dbus_iface = dbus.Interface(proxy, dbus_interface="org.gnome.SettingsDaemon.DateTimeMechanism")
++ self.date_time_wrapper = DateTimeWrapper()
+
+ self.timezones = tz.load_db()
+
+@@ -789,7 +842,7 @@ class TimeZoneSelectorWidget(Gtk.HBox):
+ tree_iter = widget.get_active_iter()
+ if tree_iter != None:
+ self.selected_city = self.city_model[tree_iter][0]
+- self.dbus_iface.SetTimezone(self.selected_region+"/"+self.selected_city)
++ self.date_time_wrapper.set_timezone(self.selected_region+"/"+self.selected_city)
+ def on_region_changed(self, widget):
+ tree_iter = widget.get_active_iter()
+ if tree_iter != None:
+@@ -810,7 +863,7 @@ class TimeZoneSelectorWidget(Gtk.HBox):
+ if selected_city_iter is not None:
+ self.city_widget.set_active_iter(selected_city_iter)
+ def get_selected_zone(self):
+- tz = self.dbus_iface.GetTimezone()
++ tz = self.date_time_wrapper.get_timezone()
+ if "/" in tz:
+ i = tz.index("/")
+ region = tz[:i]
+@@ -822,8 +875,7 @@ class TimeZoneSelectorWidget(Gtk.HBox):
+ class ChangeTimeWidget(Gtk.HBox):
+ def __init__(self):
+ super(ChangeTimeWidget, self).__init__()
+- proxy = dbus.SystemBus().get_object("org.gnome.SettingsDaemon.DateTimeMechanism", "/")
+- self.dbus_iface = dbus.Interface(proxy, dbus_interface="org.gnome.SettingsDaemon.DateTimeMechanism")
++ self.date_time_wrapper = DateTimeWrapper()
+
+ # Ensures we are setting the system time only when the user changes it
+ self.changedOnTimeout = False
+@@ -949,7 +1001,7 @@ class ChangeTimeWidget(Gtk.HBox):
+ self._time_to_set = None
+ self._setting_time_lock.release()
+
+- self.dbus_iface.SetTime(time_to_set)
++ self.date_time_wrapper.set_time(time_to_set)
+
+ # Check whether another request to set the time was done since this thread started
+ self._setting_time_lock.acquire()
+@@ -1129,7 +1181,7 @@ class MainWindow:
+ sidePage.add_widget(Gtk.LinkButton.new_with_label("http://www.foragoodstrftime.com/", _("Generate your own date formats")))
+ self.ntpCheckButton = None
+ try:
+- self.ntpCheckButton = DBusCheckButton(_("Use network time"), "org.gnome.SettingsDaemon.DateTimeMechanism", "/", "GetUsingNtp", "SetUsingNtp")
++ self.ntpCheckButton = NtpCheckButton(_("Use network time"))
+ sidePage.add_widget(self.ntpCheckButton)
+ except:
+ pass
+--
+1.7.12
+