summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-12-21 08:22:29 +0000
committerAchim Gottinger <achim@gentoo.org>2000-12-21 08:22:29 +0000
commit3d131c1ca5764e9dada5158d182d3f72306b0ea9 (patch)
tree7ce4ecec94ba43c4d62758d74069627d1aab1105 /gnome-libs
parent*** empty log message *** (diff)
downloadgentoo-2-3d131c1ca5764e9dada5158d182d3f72306b0ea9.tar.gz
gentoo-2-3d131c1ca5764e9dada5158d182d3f72306b0ea9.tar.bz2
gentoo-2-3d131c1ca5764e9dada5158d182d3f72306b0ea9.zip
*** empty log message ***
Diffstat (limited to 'gnome-libs')
-rw-r--r--gnome-libs/gb/files/digest-gb-0.0.161
-rw-r--r--gnome-libs/gb/gb-0.0.16.ebuild32
-rw-r--r--gnome-libs/libgda/files/digest-libgda-0.2.11
-rw-r--r--gnome-libs/libgda/libgda-0.2.1.ebuild38
4 files changed, 72 insertions, 0 deletions
diff --git a/gnome-libs/gb/files/digest-gb-0.0.16 b/gnome-libs/gb/files/digest-gb-0.0.16
new file mode 100644
index 000000000000..6c699c8d3105
--- /dev/null
+++ b/gnome-libs/gb/files/digest-gb-0.0.16
@@ -0,0 +1 @@
+MD5 e7ff8b79afbc2ae88a40a45703fdaab3 gb-0.0.16.tar.gz
diff --git a/gnome-libs/gb/gb-0.0.16.ebuild b/gnome-libs/gb/gb-0.0.16.ebuild
new file mode 100644
index 000000000000..8b4fb871f777
--- /dev/null
+++ b/gnome-libs/gb/gb-0.0.16.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Basic"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gnome-libs-1.2.8"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
+
+
+
diff --git a/gnome-libs/libgda/files/digest-libgda-0.2.1 b/gnome-libs/libgda/files/digest-libgda-0.2.1
new file mode 100644
index 000000000000..fa9eaf0e0f16
--- /dev/null
+++ b/gnome-libs/libgda/files/digest-libgda-0.2.1
@@ -0,0 +1 @@
+MD5 c8085ace5cfe9beb815fba386dc21164 libgda-0.2.1.tar.gz
diff --git a/gnome-libs/libgda/libgda-0.2.1.ebuild b/gnome-libs/libgda/libgda-0.2.1.ebuild
new file mode 100644
index 000000000000..3114f3d00784
--- /dev/null
+++ b/gnome-libs/libgda/libgda-0.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-db/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+DEPEND=">=gnome-base/gconf-0.11
+ >=dev-db/mysql-3.23.26
+ >=dev-db/unixODBC-1.8.13
+ >=net-nds/openldap-1.2.11"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --with-mysql=/usr --with-ldap=/usr --with-odbc
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome \
+ GDA_oafinfodir=${D}/opt/gnome/share/oaf install
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README THANKS TODO
+}
+
+
+
+