summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-25 13:04:23 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-25 13:04:23 +0000
commit5f2ca679b3c13b3b0daf21fa68dce556417237aa (patch)
tree77e24fa0fda5dab3f46eee6499025402c41493a0 /gnome-libs
parent*** empty log message *** (diff)
downloadgentoo-2-5f2ca679b3c13b3b0daf21fa68dce556417237aa.tar.gz
gentoo-2-5f2ca679b3c13b3b0daf21fa68dce556417237aa.tar.bz2
gentoo-2-5f2ca679b3c13b3b0daf21fa68dce556417237aa.zip
*** empty log message ***
Diffstat (limited to 'gnome-libs')
-rw-r--r--gnome-libs/ammonite/ammonite-0.8.1.ebuild32
-rw-r--r--gnome-libs/ammonite/files/digest-ammonite-0.8.11
-rw-r--r--gnome-libs/gb/files/digest-gb-0.0.151
-rw-r--r--gnome-libs/gb/gb-0.0.15.ebuild32
-rw-r--r--gnome-libs/libgda/files/digest-libgda-0.2.01
-rw-r--r--gnome-libs/libgda/libgda-0.1.0.ebuild3
-rw-r--r--gnome-libs/libgda/libgda-0.2.0.ebuild38
-rw-r--r--gnome-libs/libole2/libole2-0.1.7.ebuild2
-rw-r--r--gnome-libs/medusa/files/digest-medusa-0.2.21
-rw-r--r--gnome-libs/medusa/medusa-0.2.2.ebuild32
10 files changed, 142 insertions, 1 deletions
diff --git a/gnome-libs/ammonite/ammonite-0.8.1.ebuild b/gnome-libs/ammonite/ammonite-0.8.1.ebuild
new file mode 100644
index 000000000000..ad9a3522bfd0
--- /dev/null
+++ b/gnome-libs/ammonite/ammonite-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-libs/ammonite/ammonite-0.8.1.ebuild,v 1.1 2000/11/25 13:01:22 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libgtop"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gnome-libs-1.2.8
+ >=gnome-base/libxml-1.8.10-r1"
+
+src_compile() {
+ cd ${S}
+ #LDFLAGS="-lncurses"
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+ dodoc ABOUT-NLS AUTHORS COPYING* HACKING README NEWS
+ dodoc TODO doc/*.txt
+
+}
+
+
+
+
diff --git a/gnome-libs/ammonite/files/digest-ammonite-0.8.1 b/gnome-libs/ammonite/files/digest-ammonite-0.8.1
new file mode 100644
index 000000000000..4f4b27c83b60
--- /dev/null
+++ b/gnome-libs/ammonite/files/digest-ammonite-0.8.1
@@ -0,0 +1 @@
+MD5 a0df75276f3b7c76ea4c881541634e3b ammonite-0.8.1.tar.gz
diff --git a/gnome-libs/gb/files/digest-gb-0.0.15 b/gnome-libs/gb/files/digest-gb-0.0.15
new file mode 100644
index 000000000000..1b5045bd10a2
--- /dev/null
+++ b/gnome-libs/gb/files/digest-gb-0.0.15
@@ -0,0 +1 @@
+MD5 3e59330868d23b5ee4e12cb9a81f9a7c gb-0.0.15.tar.gz
diff --git a/gnome-libs/gb/gb-0.0.15.ebuild b/gnome-libs/gb/gb-0.0.15.ebuild
new file mode 100644
index 000000000000..5cf8dedd74ef
--- /dev/null
+++ b/gnome-libs/gb/gb-0.0.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Basic"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gnome-libs-1.2.4"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
+
+
+
diff --git a/gnome-libs/libgda/files/digest-libgda-0.2.0 b/gnome-libs/libgda/files/digest-libgda-0.2.0
new file mode 100644
index 000000000000..364ea11d38d6
--- /dev/null
+++ b/gnome-libs/libgda/files/digest-libgda-0.2.0
@@ -0,0 +1 @@
+MD5 58b1b943f1987cf01876ff04546f2a30 libgda-0.2.0.tar.gz
diff --git a/gnome-libs/libgda/libgda-0.1.0.ebuild b/gnome-libs/libgda/libgda-0.1.0.ebuild
index 95e6d9f86717..62f0af43d009 100644
--- a/gnome-libs/libgda/libgda-0.1.0.ebuild
+++ b/gnome-libs/libgda/libgda-0.1.0.ebuild
@@ -22,7 +22,7 @@ src_unpack() {
src_compile() {
cd ${S}
try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-mysql=/usr --with-ldap=/usr --with-odbc --with-catgets
+ --with-mysql=/usr --with-ldap=/usr --with-odbc
try make
}
@@ -35,3 +35,4 @@ src_install() {
+
diff --git a/gnome-libs/libgda/libgda-0.2.0.ebuild b/gnome-libs/libgda/libgda-0.2.0.ebuild
new file mode 100644
index 000000000000..26a88460cc99
--- /dev/null
+++ b/gnome-libs/libgda/libgda-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-db/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+DEPEND=">=gnome-base/gconf-0.10
+ >=gnome-base/gnome-libs-1.2.4
+ >=dev-db/mysql-3.23.26
+ >=dev-db/unixODBC-1.8.13
+ >=net-nds/openldap-1.2.11"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --with-mysql=/usr --with-ldap=/usr --with-odbc
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README THANKS TODO
+}
+
+
+
+
diff --git a/gnome-libs/libole2/libole2-0.1.7.ebuild b/gnome-libs/libole2/libole2-0.1.7.ebuild
index 018266bfd27b..ba8cd5502bbf 100644
--- a/gnome-libs/libole2/libole2-0.1.7.ebuild
+++ b/gnome-libs/libole2/libole2-0.1.7.ebuild
@@ -9,6 +9,8 @@ DESCRIPTION="libole2"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
+DEPEND=">=dev-libs/glib-1.2.8"
+
src_unpack() {
unpack ${A}
}
diff --git a/gnome-libs/medusa/files/digest-medusa-0.2.2 b/gnome-libs/medusa/files/digest-medusa-0.2.2
new file mode 100644
index 000000000000..918055a20776
--- /dev/null
+++ b/gnome-libs/medusa/files/digest-medusa-0.2.2
@@ -0,0 +1 @@
+MD5 19066c59e85fa81d8a24966d24c17291 medusa-0.2.2.tar.gz
diff --git a/gnome-libs/medusa/medusa-0.2.2.ebuild b/gnome-libs/medusa/medusa-0.2.2.ebuild
new file mode 100644
index 000000000000..78ad57b5c4ab
--- /dev/null
+++ b/gnome-libs/medusa/medusa-0.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-libs/medusa/medusa-0.2.2.ebuild,v 1.1 2000/11/25 13:01:23 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="medusa"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gtkhtml-0.7"
+
+src_compile() {
+ cd ${S}
+ try LDFLAGS=\"-L/opt/gnome/lib -lunicode -lpspell\" \
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+
+
+
+
+
+