summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
commit7bccea6a9acc26c9c0c2c800b7a84094890c9a29 (patch)
tree9b5b36d6b92c1bda2bf2c7bda81abc01c26df605 /gnome-libs
parent*** empty log message *** (diff)
downloadgentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.gz
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.bz2
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.zip
*** empty log message ***
Diffstat (limited to 'gnome-libs')
-rw-r--r--gnome-libs/gb/files/digest-gb-0.0.191
-rw-r--r--gnome-libs/gb/gb-0.0.19.ebuild26
-rw-r--r--gnome-libs/libole2/files/digest-libole2-0.2.31
-rw-r--r--gnome-libs/libole2/libole2-0.2.3.ebuild27
-rw-r--r--gnome-libs/libxml2/files/digest-libxml2-2.3.91
-rw-r--r--gnome-libs/libxml2/libxml2-2.3.9.ebuild35
-rw-r--r--gnome-libs/libxslt/files/digest-libxslt-0.9.01
-rw-r--r--gnome-libs/libxslt/libxslt-0.9.0.ebuild31
8 files changed, 123 insertions, 0 deletions
diff --git a/gnome-libs/gb/files/digest-gb-0.0.19 b/gnome-libs/gb/files/digest-gb-0.0.19
new file mode 100644
index 000000000000..4f6a08611580
--- /dev/null
+++ b/gnome-libs/gb/files/digest-gb-0.0.19
@@ -0,0 +1 @@
+MD5 b0d75995ce1195a8f0d4aee40ed0ddea gb-0.0.19.tar.gz
diff --git a/gnome-libs/gb/gb-0.0.19.ebuild b/gnome-libs/gb/gb-0.0.19.ebuild
new file mode 100644
index 000000000000..03f7bdbd0fa4
--- /dev/null
+++ b/gnome-libs/gb/gb-0.0.19.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Basic"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gnome-print-0.29"
+
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
+
+
+
diff --git a/gnome-libs/libole2/files/digest-libole2-0.2.3 b/gnome-libs/libole2/files/digest-libole2-0.2.3
new file mode 100644
index 000000000000..fef7dca25135
--- /dev/null
+++ b/gnome-libs/libole2/files/digest-libole2-0.2.3
@@ -0,0 +1 @@
+MD5 b9c620d0988ddd1dc786e9306cd454df libole2-0.2.3.tar.gz
diff --git a/gnome-libs/libole2/libole2-0.2.3.ebuild b/gnome-libs/libole2/libole2-0.2.3.ebuild
new file mode 100644
index 000000000000..4d58dbd19f3f
--- /dev/null
+++ b/gnome-libs/libole2/libole2-0.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libole2"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=dev-libs/glib-1.2.8"
+
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
+
+
+
diff --git a/gnome-libs/libxml2/files/digest-libxml2-2.3.9 b/gnome-libs/libxml2/files/digest-libxml2-2.3.9
new file mode 100644
index 000000000000..2a8dd06fe759
--- /dev/null
+++ b/gnome-libs/libxml2/files/digest-libxml2-2.3.9
@@ -0,0 +1 @@
+MD5 e436e69347c52f7a398edbd504440ac4 libxml2-2.3.9.tar.gz
diff --git a/gnome-libs/libxml2/libxml2-2.3.9.ebuild b/gnome-libs/libxml2/libxml2-2.3.9.ebuild
new file mode 100644
index 000000000000..fcde8018b5ed
--- /dev/null
+++ b/gnome-libs/libxml2/libxml2-2.3.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-libs/libxml2/libxml2-2.3.9.ebuild,v 1.1 2001/06/04 06:41:14 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libxml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libxml/${A}
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/libxml/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+ local myconf
+ try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --with-zlib
+ try make
+}
+
+src_install() {
+ try make install prefix=${D}/usr sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
+
+
+
+
+
+
+
diff --git a/gnome-libs/libxslt/files/digest-libxslt-0.9.0 b/gnome-libs/libxslt/files/digest-libxslt-0.9.0
new file mode 100644
index 000000000000..30bf8a1e78ff
--- /dev/null
+++ b/gnome-libs/libxslt/files/digest-libxslt-0.9.0
@@ -0,0 +1 @@
+MD5 6e94d0df6653f8082c3750fa964488f8 libxslt-0.9.0.tar.gz
diff --git a/gnome-libs/libxslt/libxslt-0.9.0.ebuild b/gnome-libs/libxslt/libxslt-0.9.0.ebuild
new file mode 100644
index 000000000000..5067ab0fc7da
--- /dev/null
+++ b/gnome-libs/libxslt/libxslt-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-libs/libxslt/libxslt-0.9.0.ebuild,v 1.1 2001/06/04 06:41:14 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libxslt"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc sys-devel/perl
+ >=gnome-libs/libxml2-2.3.9"
+
+RDEPEND="virtual/glibc
+ >=gnome-libs/libxml2-2.3.9"
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}
+