summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-22 04:58:31 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-22 04:58:31 +0000
commit217e7a0b8ade5940ba79b8405c5644dc60566a8b (patch)
tree03906edb430bd3c11068a32e8ecfae4d29d65f2a /gnome-office
parentCleanup (diff)
downloadgentoo-2-217e7a0b8ade5940ba79b8405c5644dc60566a8b.tar.gz
gentoo-2-217e7a0b8ade5940ba79b8405c5644dc60566a8b.tar.bz2
gentoo-2-217e7a0b8ade5940ba79b8405c5644dc60566a8b.zip
*** empty log message ***
Diffstat (limited to 'gnome-office')
-rw-r--r--gnome-office/gnumeric/gnumeric-0.61-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnome-office/gnumeric/gnumeric-0.61-r1.ebuild b/gnome-office/gnumeric/gnumeric-0.61-r1.ebuild
new file mode 100644
index 000000000000..ba48cd4417c8
--- /dev/null
+++ b/gnome-office/gnumeric/gnumeric-0.61-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.61-r1.ebuild,v 1.1 2001/01/22 04:55:46 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=sys-devel/perl-5
+ >=virtual/python-1.5.2
+ >=gnome-base/gal-0.3.0
+ >=gnome-libs/gb-0.0.17
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28
+ >=gnome-libs/libgda-0.2.0 ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:"%d,:"%d",:' configure.orig > configure
+}
+
+src_compile() {
+ cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
+ LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ ${myconf} --with-gb
+ cd ${S}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+