summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-13 08:38:51 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-13 08:38:51 +0000
commit2c03a7729460a1c5af5cff5f55c478d4ad5dc68c (patch)
tree5825deea1786adc9fadea929dfed5a2793572ed2 /gnome-office
parentnew (diff)
downloadgentoo-2-2c03a7729460a1c5af5cff5f55c478d4ad5dc68c.tar.gz
gentoo-2-2c03a7729460a1c5af5cff5f55c478d4ad5dc68c.tar.bz2
gentoo-2-2c03a7729460a1c5af5cff5f55c478d4ad5dc68c.zip
updated to 0.69, could someone please test this package, gnumeric >= 0.68 has been segfaulting on one of my machine and worked fine on the other
Diffstat (limited to 'gnome-office')
-rw-r--r--gnome-office/gnumeric/files/digest-gnumeric-0.691
-rw-r--r--gnome-office/gnumeric/gnumeric-0.69.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/gnome-office/gnumeric/files/digest-gnumeric-0.69 b/gnome-office/gnumeric/files/digest-gnumeric-0.69
new file mode 100644
index 000000000000..8cf29eafdce3
--- /dev/null
+++ b/gnome-office/gnumeric/files/digest-gnumeric-0.69
@@ -0,0 +1 @@
+MD5 6d6fc6220bcd3cbb3f444009134c30a7 gnumeric-0.69.tar.gz
diff --git a/gnome-office/gnumeric/gnumeric-0.69.ebuild b/gnome-office/gnumeric/gnumeric-0.69.ebuild
new file mode 100644
index 000000000000..10f807623f1c
--- /dev/null
+++ b/gnome-office/gnumeric/gnumeric-0.69.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.66.ebuild,v 1.1 2001/06/28 09:47:57 hallski Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=gnome-base/gnome-print-0.29
+ >=gnome-base/gal-0.8.0
+ >=gnome-base/libxml-1.8.14
+ >=gnome-libs/libole2-0.2.3
+ >=dev-util/xml-i18n-tools-0.8.4
+ perl? ( >=sys-devel/perl-5 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( >=gnome-libs/gb-0.0.19 )
+ libgda? ( >=gnome-libs/libgda-0.2.9 )
+ nls? ( sys-devel/gettext )
+ bonobo? ( >=gnome-base/bonobo-1.0 )"
+
+RDEPEND=">=gnome-base/gnome-print-0.29
+ >=gnome-base/gal-0.8.0
+ gb? ( >=gnome-libs/gb-0.0.19 )
+ libgda? ( >=gnome-libs/libgda-0.2.9 )
+ bonobo? ( >=gnome-base/bonobo-1.0 ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:"%d,:"%d",:' configure.orig > configure
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ -z "`use bonobo`" ] ; then
+ myconf="$myconf --without-bonobo"
+ fi
+ if [ "`use gb`" ]; then
+ #does not work atm
+ myconf="$myconf --without-gb"
+ else
+ myconf="$myconf --without-gb"
+ fi
+ if [ "`use perl`" ]; then
+ myconf="$myconf --with-perl"
+ else
+ myconf="$myconf --without-perl"
+ fi
+ if [ "`use python`" ]; then
+ myconf="$myconf --with-python"
+ else
+ myconf="$myconf --without-python"
+ fi
+ if [ "`use libgda`" ]; then
+ myconf="$myconf --with-gda"
+ else
+ myconf="$myconf --without-gda"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome --without-evolution ${myconf}
+ cd ${S}
+ try pmake
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+