summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-12-10 10:03:52 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-12-10 10:03:52 +0000
commite2d8b8886b5748933577fd2c22f51b4b675f3ee2 (patch)
tree7ecb2b84dd6fec49be520a7ea60c5f10505a57a5 /gnustep-apps
parentBumping to version 0.6.1 (diff)
downloadgentoo-2-e2d8b8886b5748933577fd2c22f51b4b675f3ee2.tar.gz
gentoo-2-e2d8b8886b5748933577fd2c22f51b4b675f3ee2.tar.bz2
gentoo-2-e2d8b8886b5748933577fd2c22f51b4b675f3ee2.zip
Add patch to make it compile with gnustep-base 1.15
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/terminal/ChangeLog7
-rw-r--r--gnustep-apps/terminal/files/terminal-0.9.5_pre20060324-gnustep-base1.15.patch10
-rw-r--r--gnustep-apps/terminal/terminal-0.9.5_pre20060324-r1.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/gnustep-apps/terminal/ChangeLog b/gnustep-apps/terminal/ChangeLog
index 4785a6d3cf98..b8f33e25d20d 100644
--- a/gnustep-apps/terminal/ChangeLog
+++ b/gnustep-apps/terminal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-apps/terminal
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/terminal/ChangeLog,v 1.15 2007/09/10 18:31:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/terminal/ChangeLog,v 1.16 2007/12/10 10:03:51 voyageur Exp $
+
+ 10 Dec 2007; Bernard Cafarelli <voyageur@gentoo.org>
+ +files/terminal-0.9.5_pre20060324-gnustep-base1.15.patch,
+ terminal-0.9.5_pre20060324-r1.ebuild:
+ Add patch to make it compile with gnustep-base 1.15
*terminal-0.9.5_pre20060324-r1 (10 Sep 2007)
diff --git a/gnustep-apps/terminal/files/terminal-0.9.5_pre20060324-gnustep-base1.15.patch b/gnustep-apps/terminal/files/terminal-0.9.5_pre20060324-gnustep-base1.15.patch
new file mode 100644
index 000000000000..e58968ef7cef
--- /dev/null
+++ b/gnustep-apps/terminal/files/terminal-0.9.5_pre20060324-gnustep-base1.15.patch
@@ -0,0 +1,10 @@
+--- Terminal/TerminalViewPrefs.m.orig 2007-12-10 10:54:08.000000000 +0100
++++ Terminal/TerminalViewPrefs.m 2007-12-10 10:54:12.000000000 +0100
+@@ -15,6 +15,7 @@
+ #include <AppKit/NSColorPanel.h>
+ #include <AppKit/NSColorWell.h>
+ #include <AppKit/NSFont.h>
++#include <AppKit/NSFontManager.h>
+ #include <AppKit/NSGraphics.h>
+ #include <AppKit/NSImage.h>
+ #include <AppKit/NSTextField.h>
diff --git a/gnustep-apps/terminal/terminal-0.9.5_pre20060324-r1.ebuild b/gnustep-apps/terminal/terminal-0.9.5_pre20060324-r1.ebuild
index a32ca3555197..3fd28277921b 100644
--- a/gnustep-apps/terminal/terminal-0.9.5_pre20060324-r1.ebuild
+++ b/gnustep-apps/terminal/terminal-0.9.5_pre20060324-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/terminal/terminal-0.9.5_pre20060324-r1.ebuild,v 1.1 2007/09/10 18:31:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/terminal/terminal-0.9.5_pre20060324-r1.ebuild,v 1.2 2007/12/10 10:03:51 voyageur Exp $
inherit gnustep-2
@@ -20,4 +20,5 @@ src_unpack() {
# on Solaris -lutil doesn't exist, which hence doesn't provide forkpty
epatch "${FILESDIR}"/${P}-solaris.patch
epatch "${FILESDIR}"/${P}-size_t.patch
+ epatch "${FILESDIR}"/${P}-gnustep-base1.15.patch
}