summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-07-25 12:11:23 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-07-25 12:11:23 +0000
commit269bfddc6d62d6f6b3da8542e4d3e7651763b724 (patch)
treea0ebb3a10255a1808b224c11fcd99f8c3dc0c8a1 /gnustep-base/libobjc2
parentbump to texlive 2012 released version (diff)
downloadgentoo-2-269bfddc6d62d6f6b3da8542e4d3e7651763b724.tar.gz
gentoo-2-269bfddc6d62d6f6b3da8542e4d3e7651763b724.tar.bz2
gentoo-2-269bfddc6d62d6f6b3da8542e4d3e7651763b724.zip
Version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base/libobjc2')
-rw-r--r--gnustep-base/libobjc2/ChangeLog7
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.6.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
index 1d4ef4c09864..ae097fe352f0 100644
--- a/gnustep-base/libobjc2/ChangeLog
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-base/libobjc2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.9 2012/02/20 10:10:43 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.10 2012/07/25 12:11:23 voyageur Exp $
+
+*libobjc2-1.6.1 (25 Jul 2012)
+
+ 25 Jul 2012; Bernard Cafarelli <voyageur@gentoo.org> +libobjc2-1.6.1.ebuild:
+ Version bump
20 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> libobjc2-1.6.ebuild:
Force clang use, as gcc-4.6 does not work and clang is needed anyway for
diff --git a/gnustep-base/libobjc2/libobjc2-1.6.1.ebuild b/gnustep-base/libobjc2/libobjc2-1.6.1.ebuild
new file mode 100644
index 000000000000..9de1edb245d8
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-1.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.6.1.ebuild,v 1.1 2012/07/25 12:11:23 voyageur Exp $
+
+EAPI=4
+inherit multilib
+
+# We need gnustep-make, but gnustep-make can depend on libobjc
+# Use a temporary setup to install in /usr/
+GSMAKE=gnustep-make-2.6.2
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
+ ftp://ftp.gnustep.org/pub/gnustep/core/${GSMAKE}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+boehm-gc"
+
+RDEPEND="boehm-gc? ( dev-libs/boehm-gc )"
+DEPEND="${DEPEND}
+ >=sys-devel/clang-2.9"
+
+GSMAKE_S=${WORKDIR}/${GSMAKE}
+
+src_prepare() {
+ # Remove CFLAGS from assembly calls
+ sed -e "s/\$(ALL_CFLAGS)//" -i GNUmakefile || die "Assembly sed failed"
+ # Multilib-strict
+ cd "${GSMAKE_S}"
+ sed -e "s/lib/$(get_libdir)/g" \
+ -i FilesystemLayouts/fhs-system || die "multilib path sed failed"
+}
+
+src_configure() {
+ export CC=clang
+
+ cd "${GSMAKE_S}"
+ econf --with-layout=fhs-system
+}
+
+src_compile() {
+ local gb
+ use boehm-gc \
+ && gb="boehm_gc=yes" \
+ || gb="boehm_gc=no"
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" messages=yes ${gb}
+}
+
+src_install() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" \
+ GNUSTEP_CONFIG_FILE="${GSMAKE_S}"/GNUstep.conf \
+ GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
+ messages=yes \
+ DESTDIR="${D}" install
+}