summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-18 14:52:25 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-18 14:52:25 +0000
commit4300a74047a4e415502afb1bde37f908c525f401 (patch)
tree44f8ad25731f6dc5cca20c184ceaee73544e1b03 /gnustep-base
parentStable on ppc wrt bug 189347 (diff)
downloadgentoo-2-4300a74047a4e415502afb1bde37f908c525f401.tar.gz
gentoo-2-4300a74047a4e415502afb1bde37f908c525f401.tar.bz2
gentoo-2-4300a74047a4e415502afb1bde37f908c525f401.zip
Bump from GNUstep overlay. Using new gnustep eclasses
(Portage version: 2.1.2.11)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog8
-rw-r--r--gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.03
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild43
3 files changed, 53 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index ebd93bf594b5..e46a42e1b617 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-gui
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.44 2007/07/22 10:25:37 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.45 2007/08/18 14:52:24 grobian Exp $
+
+*gnustep-gui-0.12.0 (18 Aug 2007)
+
+ 18 Aug 2007; Fabian Groffen <grobian@gentoo.org>
+ +gnustep-gui-0.12.0.ebuild:
+ Bump from GNUstep overlay. Using new gnustep eclasses
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
gnustep-gui-0.9.5.ebuild, gnustep-gui-0.10.3.ebuild,
diff --git a/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.0 b/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.0
new file mode 100644
index 000000000000..745c79f9d5ee
--- /dev/null
+++ b/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.0
@@ -0,0 +1,3 @@
+MD5 13f1ec9910a99105ed0f1f79f2ff2db0 gnustep-gui-0.12.0.tar.gz 1738576
+RMD160 886839d60065dbb598d9aefed929a820a0b5dc36 gnustep-gui-0.12.0.tar.gz 1738576
+SHA256 07fc74efb2db23a4499289aa690754d533c19897681152add93a074c05fd8a6e gnustep-gui-0.12.0.tar.gz 1738576
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild
new file mode 100644
index 000000000000..7ed7d4d1229a
--- /dev/null
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild,v 1.1 2007/08/18 14:52:24 grobian Exp $
+
+inherit gnustep-base
+
+DESCRIPTION="Library of GUI classes written in Obj-C"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="jpeg gif png cups"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-base-1.14.0
+ x11-libs/libXt
+ >=media-libs/tiff-3
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1 )
+ png? ( >=media-libs/libpng-1.2 )
+ cups? ( >=net-print/cups-1.1 )
+ media-libs/audiofile
+ app-text/aspell"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ egnustep_env
+
+ myconf="--with-tiff-include=/usr/include --with-tiff-library=/usr/lib"
+ use gif && myconf="$myconf --disable-ungif --enable-libgif"
+ myconf="$myconf `use_enable jpeg`"
+ myconf="$myconf `use_enable png`"
+ myconf="$myconf `use_enable cups`"
+ # gsnd is disabled until portaudio-19 is unmasked in portage
+ myconf="$myconf --disable-gsnd"
+
+ econf $myconf || die "configure failed"
+
+ egnustep_make || die
+}