summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-09-27 20:09:55 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-09-27 20:09:55 +0000
commit5a3c9b3f13db7fd0ea056a4171188df78a4cab65 (patch)
treeac3589de9324cb06a07a126af0fab5634714830c /gnustep-base
parentVersion bump. (diff)
downloadgentoo-2-5a3c9b3f13db7fd0ea056a4171188df78a4cab65.tar.gz
gentoo-2-5a3c9b3f13db7fd0ea056a4171188df78a4cab65.tar.bz2
gentoo-2-5a3c9b3f13db7fd0ea056a4171188df78a4cab65.zip
Switch to cmake build system, also fixes sandbox violation reported by José Romildo Malaquias in bug #486190
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/libobjc2/ChangeLog7
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.7.ebuild57
-rw-r--r--gnustep-base/libobjc2/metadata.xml2
3 files changed, 28 insertions, 38 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
index 61fa917ea57d..21f20af2c448 100644
--- a/gnustep-base/libobjc2/ChangeLog
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-base/libobjc2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.12 2013/09/26 11:55:20 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.13 2013/09/27 20:09:55 voyageur Exp $
+
+ 27 Sep 2013; Bernard Cafarelli <voyageur@gentoo.org> libobjc2-1.7.ebuild,
+ metadata.xml:
+ Switch to cmake build system, also fixes sandbox violation reported by José
+ Romildo Malaquias in bug #486190
*libobjc2-1.7 (26 Sep 2013)
diff --git a/gnustep-base/libobjc2/libobjc2-1.7.ebuild b/gnustep-base/libobjc2/libobjc2-1.7.ebuild
index 36a42c175f70..495722676368 100644
--- a/gnustep-base/libobjc2/libobjc2-1.7.ebuild
+++ b/gnustep-base/libobjc2/libobjc2-1.7.ebuild
@@ -1,57 +1,42 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.7.ebuild,v 1.1 2013/09/26 11:55:20 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.7.ebuild,v 1.2 2013/09/27 20:09:55 voyageur Exp $
EAPI=5
-inherit multilib
+inherit cmake-utils
-# We need gnustep-make, but gnustep-make can depend on libobjc
-# Use a temporary setup to install in /usr/
-GSMAKE=gnustep-make-2.6.5
DESCRIPTION="GNUstep Objective-C runtime"
HOMEPAGE="http://www.gnustep.org"
-SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
- ftp://ftp.gnustep.org/pub/gnustep/core/${GSMAKE}.tar.gz"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+boehm-gc"
+IUSE="boehm-gc cxx test"
-RDEPEND="boehm-gc? ( dev-libs/boehm-gc )"
+RDEPEND="boehm-gc? ( dev-libs/boehm-gc )
+ cxx? ( sys-libs/libcxx )"
DEPEND="${DEPEND}
>=sys-devel/clang-2.9"
-GSMAKE_S=${WORKDIR}/${GSMAKE}
-
src_prepare() {
- # Remove CFLAGS from assembly calls
- sed -e "s/\$(ALL_CFLAGS)//" -i GNUmakefile || die "Assembly sed failed"
- # Multilib-strict
- cd "${GSMAKE_S}"
- sed -e "s/lib/$(get_libdir)/g" \
- -i FilesystemLayouts/fhs-system || die "multilib path sed failed"
+ if ! use cxx;
+ then
+ sed -e 's/addtest_flags(CXXExceptions.*//' \
+ -i Test/CMakeLists.txt || die "test sed failed"
+ fi
}
src_configure() {
export CC=clang
-
- cd "${GSMAKE_S}"
- econf --with-layout=fhs-system
-}
-
-src_compile() {
- local gb
- use boehm-gc \
- && gb="boehm_gc=yes" \
- || gb="boehm_gc=no"
- emake GNUSTEP_MAKEFILES="${GSMAKE_S}" messages=yes ${gb}
-}
-
-src_install() {
- emake GNUSTEP_MAKEFILES="${GSMAKE_S}" \
- GNUSTEP_CONFIG_FILE="${GSMAKE_S}"/GNUstep.conf \
- GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
- messages=yes \
- DESTDIR="${D}" install
+ export CXX=clang++
+
+ export PREFIX=/usr
+ local mycmakeargs=(
+ -DGNUSTEP_CONFIG=GNUSTEP_CONFIG-NOTFOUND
+ $(cmake-utils_use boehm-gc BOEHM_GC)
+ $(cmake-utils_use_enable cxx OBJCXX)
+ $(cmake-utils_use test TESTS)
+ )
+ cmake-utils_src_configure
}
diff --git a/gnustep-base/libobjc2/metadata.xml b/gnustep-base/libobjc2/metadata.xml
index 349762508758..ce7e3f6fba4a 100644
--- a/gnustep-base/libobjc2/metadata.xml
+++ b/gnustep-base/libobjc2/metadata.xml
@@ -27,6 +27,6 @@ Both ABIs support the following feature above and beyond the GCC runtime:
</longdescription>
<use>
<flag name='boehm-gc'>Enable Hans Boehm's garbage collector
- (<pkg>dev-libs/boehm-gc</pkg>)</flag>
+ (<pkg>dev-libs/boehm-gc</pkg>). Not recommended by upstream</flag>
</use>
</pkgmetadata>