summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-10-20 13:16:57 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-10-20 13:16:57 +0000
commita0a20e462afd91628ace81b4b609c7bdd3c8fd82 (patch)
tree80f98404e72bdf6abcbdec2e3a78d94a6e7a7e41 /gnustep-base
parentOutput which ebuild actually has bad EAPI (diff)
downloadgentoo-2-a0a20e462afd91628ace81b4b609c7bdd3c8fd82.tar.gz
gentoo-2-a0a20e462afd91628ace81b4b609c7bdd3c8fd82.tar.bz2
gentoo-2-a0a20e462afd91628ace81b4b609c7bdd3c8fd82.zip
Version bump, bugfix release with TLS and other security improvements, latest timezone data
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/ChangeLog9
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.24.7.ebuild68
2 files changed, 76 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-base/ChangeLog b/gnustep-base/gnustep-base/ChangeLog
index 8e7bf903c1b0..b6ea6f1d4a11 100644
--- a/gnustep-base/gnustep-base/ChangeLog
+++ b/gnustep-base/gnustep-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnustep-base/gnustep-base
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.128 2014/08/10 21:18:23 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.129 2014/10/20 13:16:57 voyageur Exp $
+
+*gnustep-base-1.24.7 (20 Oct 2014)
+
+ 20 Oct 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-base-1.24.7.ebuild:
+ Version bump, bugfix release with TLS and other security improvements, latest
+ timezone data
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
gnustep-base-1.24.6-r1.ebuild:
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.24.7.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.24.7.ebuild
new file mode 100644
index 000000000000..3297a434f7e8
--- /dev/null
+++ b/gnustep-base/gnustep-base/gnustep-base-1.24.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.24.7.ebuild,v 1.1 2014/10/20 13:16:57 voyageur Exp $
+
+EAPI=5
+inherit eutils gnustep-base
+
+DESCRIPTION="A library of general-purpose, non-graphical Objective C objects"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="+icu +libffi ssl zeroconf"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-2.6.0
+ icu? ( >=dev-libs/icu-4.0:= )
+ !libffi? ( dev-libs/ffcall
+ gnustep-base/gnustep-make[-native-exceptions] )
+ libffi? ( virtual/libffi )
+ ssl? ( net-libs/gnutls )
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.1
+ >=dev-libs/gmp-4.1
+ >=dev-libs/openssl-0.9.7
+ >=sys-libs/zlib-1.2
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ egnustep_env
+
+ local myconf
+ if use libffi;
+ then
+ myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
+ else
+ myconf="--disable-libffi --enable-ffcall"
+ fi
+
+ myconf="$myconf $(use_enable icu)"
+ myconf="$myconf $(use_enable ssl tls)"
+ myconf="$myconf $(use_enable zeroconf)"
+ myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
+ myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
+ myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"
+
+ econf $myconf
+}
+
+src_install() {
+ # We need to set LD_LIBRARY_PATH because the doc generation program
+ # uses the gnustep-base libraries. Since egnustep_env "cleans the
+ # environment" including our LD_LIBRARY_PATH, we're left no choice
+ # but doing it like this.
+
+ egnustep_env
+ egnustep_install
+
+ if use doc ; then
+ export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
+ egnustep_doc
+ fi
+ egnustep_install_config
+}