summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-03-08 15:41:06 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-03-08 15:41:06 +0000
commite366616a8b6ec337778c652e5f69bfbda75fd43f (patch)
tree315beb6eecfe20d81ba0a3aed0a3108dc52dea65 /gnustep-base
parentsqlplus binary needs pax-mark for hardened, bug#456694. Credits to Hugo Milde... (diff)
downloadgentoo-2-e366616a8b6ec337778c652e5f69bfbda75fd43f.tar.gz
gentoo-2-e366616a8b6ec337778c652e5f69bfbda75fd43f.tar.bz2
gentoo-2-e366616a8b6ec337778c652e5f69bfbda75fd43f.zip
Version bump, lots of changes in this release
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog10
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.23.0.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index 5b0441a57974..09daf5031d28 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-gui
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.99 2012/12/20 15:05:31 voyageur Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.100 2013/03/08 15:41:06 voyageur Exp $
+
+*gnustep-gui-0.23.0 (08 Mar 2013)
+
+ 08 Mar 2013; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-gui-0.23.0.ebuild:
+ Version bump, lots of changes in this release
20 Dec 2012; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-gui-0.18.0.ebuild, -files/gnustep-gui-0.18.0-libpng15.patch:
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.23.0.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.23.0.ebuild
new file mode 100644
index 000000000000..fa4b68a8c387
--- /dev/null
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.23.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.23.0.ebuild,v 1.1 2013/03/08 15:41:06 voyageur Exp $
+
+EAPI=5
+inherit gnustep-base multilib
+
+DESCRIPTION="Library of GUI classes written in Obj-C"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cups gif jpeg png speech"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ app-text/aspell
+ >=gnustep-base/gnustep-base-1.24.0
+ media-libs/audiofile
+ >=media-libs/tiff-3
+ x11-libs/libXt
+ cups? ( >=net-print/cups-1.1 )
+ gif? ( >=media-libs/giflib-4.1 )
+ jpeg? ( virtual/jpeg )
+ png? ( >=media-libs/libpng-1.2 )
+ speech? ( app-accessibility/flite )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ gnustep-base_src_prepare
+
+ # remove hardcoded -g -Werror, bug #378179
+ sed -i -e 's/-g -Werror//' \
+ Tools/say/GNUmakefile \
+ Tools/speech/GNUmakefile \
+ || die
+}
+
+src_configure() {
+ egnustep_env
+
+ local myconf=
+ use gif && myconf="--disable-ungif --enable-libgif"
+
+ econf \
+ $(use_enable cups) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable speech) \
+ --with-tiff-include="${EPREFIX}"/usr/include \
+ --with-tiff-library="${EPREFIX}"/usr/$(get_libdir) \
+ ${myconf}
+}
+
+pkg_postinst() {
+ ewarn "The shared library version has changed in this release."
+ ewarn "You will need to recompile all Applications/Tools/etc in order"
+ ewarn "to use this library. Please run revdep-rebuild to do so"
+}