summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-22 13:59:58 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-22 13:59:58 +0000
commitff18d91828fa6a97463a8b1a0d54a8cc962e4b66 (patch)
tree40201296a819ef80dd3b513db1be051747eef32a /gnustep-base
parentMajor version bump, adds support for @synchronize, general OSX 10.5 compatibi... (diff)
downloadgentoo-2-ff18d91828fa6a97463a8b1a0d54a8cc962e4b66.tar.gz
gentoo-2-ff18d91828fa6a97463a8b1a0d54a8cc962e4b66.tar.bz2
gentoo-2-ff18d91828fa6a97463a8b1a0d54a8cc962e4b66.zip
Major version bump, Nib loading refractored and improved, support for autosaving in NSDocuments, NSWindowController made a subclass of NSResponder, NSTokenField and netokenFiledCell classes added
(Portage version: 2.2_rc18/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog10
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.16.0.ebuild49
2 files changed, 58 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index a33c3283ae1b..fd69454085a3 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnustep-base/gnustep-gui
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.72 2008/11/17 13:39:22 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.73 2008/12/22 13:59:58 voyageur Exp $
+
+*gnustep-gui-0.16.0 (22 Dec 2008)
+
+ 22 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-gui-0.16.0.ebuild:
+ Major version bump, Nib loading refractored and improved, support for
+ autosaving in NSDocuments, NSWindowController made a subclass of
+ NSResponder, NSTokenField and netokenFiledCell classes added
17 Nov 2008; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-gui-0.12.1.ebuild:
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.16.0.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.16.0.ebuild
new file mode 100644
index 000000000000..40e6f0c0892d
--- /dev/null
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.16.0.ebuild,v 1.1 2008/12/22 13:59:58 voyageur Exp $
+
+inherit gnustep-base multilib
+
+DESCRIPTION="Library of GUI classes written in Obj-C"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="jpeg gif png portaudio cups"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-base-1.18.0
+ x11-libs/libXt
+ >=media-libs/tiff-3
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1 )
+ png? ( >=media-libs/libpng-1.2 )
+ !x86-fbsd? ( portaudio? ( =media-libs/portaudio-19* ) )
+ cups? ( >=net-print/cups-1.1 )
+ media-libs/audiofile
+ app-text/aspell"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ egnustep_env
+
+ myconf="--with-tiff-include=/usr/include --with-tiff-library=/usr/$(get_libdir)"
+ use gif && myconf="$myconf --disable-ungif --enable-libgif"
+ myconf="$myconf `use_enable jpeg`"
+ myconf="$myconf `use_enable png`"
+ myconf="$myconf `use_enable portaudio gsnd`"
+ myconf="$myconf `use_enable cups`"
+
+ econf $myconf || die "configure failed"
+
+ egnustep_make || die
+}
+
+pkg_postinst() {
+ ewarn "The shared library version has changed in this release."
+ ewarn "You will need to recompile all Applications/Tools/etc in order"
+ ewarn "to use this library. Please run revdep-rebuild to do so"
+}