summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-08 14:31:40 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-08 14:31:40 +0000
commit55550dcb1c1a37877c3fe01595fdb80901f812be (patch)
treed8aec9fb2c6ca63061cff4e5442b08afd4091f48 /gnustep-libs/popplerkit
parentRe-add kbio patch to 1.15, since sparc fails to build without it (diff)
downloadgentoo-2-55550dcb1c1a37877c3fe01595fdb80901f812be.tar.gz
gentoo-2-55550dcb1c1a37877c3fe01595fdb80901f812be.tar.bz2
gentoo-2-55550dcb1c1a37877c3fe01595fdb80901f812be.zip
Fix --as-needed support, bug #250175
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'gnustep-libs/popplerkit')
-rw-r--r--gnustep-libs/popplerkit/ChangeLog9
-rw-r--r--gnustep-libs/popplerkit/files/popplerkit-0.4.0-config-as-needed.patch38
-rw-r--r--gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild (renamed from gnustep-libs/popplerkit/popplerkit-0.4.0.ebuild)9
3 files changed, 54 insertions, 2 deletions
diff --git a/gnustep-libs/popplerkit/ChangeLog b/gnustep-libs/popplerkit/ChangeLog
index 4017d7e1be7f..7a24a64c7ad1 100644
--- a/gnustep-libs/popplerkit/ChangeLog
+++ b/gnustep-libs/popplerkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnustep-libs/popplerkit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/ChangeLog,v 1.15 2008/11/17 14:06:57 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/ChangeLog,v 1.16 2008/12/08 14:31:40 voyageur Exp $
+
+*popplerkit-0.4.0-r1 (08 Dec 2008)
+
+ 08 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +files/popplerkit-0.4.0-config-as-needed.patch, -popplerkit-0.4.0.ebuild,
+ +popplerkit-0.4.0-r1.ebuild:
+ Fix --as-needed support, bug #250175
17 Nov 2008; Bernard Cafarelli <voyageur@gentoo.org>
popplerkit-0.4.0.ebuild:
diff --git a/gnustep-libs/popplerkit/files/popplerkit-0.4.0-config-as-needed.patch b/gnustep-libs/popplerkit/files/popplerkit-0.4.0-config-as-needed.patch
new file mode 100644
index 000000000000..179d81309d86
--- /dev/null
+++ b/gnustep-libs/popplerkit/files/popplerkit-0.4.0-config-as-needed.patch
@@ -0,0 +1,38 @@
+--- Frameworks/PopplerKit/config.sh.orig 2008-12-08 14:43:36.000000000 +0100
++++ Frameworks/PopplerKit/config.sh 2008-12-08 14:43:51.000000000 +0100
+@@ -22,7 +22,7 @@
+ exit 1
+ fi
+ POPPLER_CFLAGS="${POPPLER_CFLAGS} `${PKG_CONFIG} --cflags fontconfig`"
+-POPPLER_LIBS="${POPPLER_LDFLAGS} `${PKG_CONFIG} --libs fontconfig`"
++POPPLER_LIBS="${POPPLER_LIBS} `${PKG_CONFIG} --libs fontconfig`"
+
+ # poppler splash device
+ ${PKG_CONFIG} --exists poppler-splash
+@@ -31,7 +31,7 @@
+ exit 1
+ fi
+ POPPLER_CFLAGS="${POPPLER_CFLAGS} `${PKG_CONFIG} --cflags poppler-splash`"
+-POPPLER_LIBS="${POPPLER_LDFLAGS} `${PKG_CONFIG} --libs poppler-splash`"
++POPPLER_LIBS="${POPPLER_LIBS} `${PKG_CONFIG} --libs poppler-splash`"
+
+ # poppler cairo device
+ ${PKG_CONFIG} --exists poppler-cairo
+@@ -42,7 +42,7 @@
+ # Disable Cairo support for now to avoid most of problem
+ # HAVE_CAIRO="YES"
+ # POPPLER_CFLAGS="${POPPLER_CFLAGS} `${PKG_CONFIG} --cflags poppler-cairo`"
+-# POPPLER_LIBS="${POPPLER_LDFLAGS} `${PKG_CONFIG} --libs poppler-cairo`"
++# POPPLER_LIBS="${POPPLER_LIBS} `${PKG_CONFIG} --libs poppler-cairo`"
+ HAVE_CAIRO="NO"
+ fi
+
+@@ -85,7 +85,7 @@
+ echo "FT_CFLAGS=${FT_CFLAGS}" >> config.make
+ echo "FT_LIBS=${FT_LIBS}" >> config.make
+ echo "ADDITIONAL_CFLAGS+=\$(POPPLER_CFLAGS) \$(FT_CFLAGS)" >> config.make
+-echo "ADDITIONAL_LDFLAGS+=\$(POPPLER_LIBS) \$(POPPLER_LIBS)" >> config.make
++echo "LIBRARIES_DEPEND_UPON+=\$(POPPLER_LIBS) \$(FT_LIBS)" >> config.make
+ # we add -I/usr/X11R6/include for older FreeBSD version.
+ echo "ADDITIONAL_INCLUDE_DIRS += -I/usr/X11R6/include" >> config.make
+ echo "HAVE_CAIRO=${HAVE_CAIRO}" >>config.make
diff --git a/gnustep-libs/popplerkit/popplerkit-0.4.0.ebuild b/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild
index c3a2e216bdd7..31ce3cff0c8c 100644
--- a/gnustep-libs/popplerkit/popplerkit-0.4.0.ebuild
+++ b/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/popplerkit-0.4.0.ebuild,v 1.2 2008/11/17 14:06:57 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild,v 1.1 2008/12/08 14:31:40 voyageur Exp $
inherit gnustep-2
@@ -19,6 +19,13 @@ RDEPEND=">=app-text/poppler-0.6
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-config-as-needed.patch
+}
+
src_compile() {
# Compile MissingKit separately
cd "${S}"/MissingKit