summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo Arrifano <miknix@gentoo.org>2009-07-06 19:31:04 +0000
committerAngelo Arrifano <miknix@gentoo.org>2009-07-06 19:31:04 +0000
commit984d635a144008f3839437473ddc2deb6dc6bf50 (patch)
tree6a7f21ffaf5821f9d883885332ec5123890e7dad /gpe-base
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-984d635a144008f3839437473ddc2deb6dc6bf50.tar.gz
gentoo-2-984d635a144008f3839437473ddc2deb6dc6bf50.tar.bz2
gentoo-2-984d635a144008f3839437473ddc2deb6dc6bf50.zip
Initial commit, imported from GPE overlay and based on bug 101393 .
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'gpe-base')
-rw-r--r--gpe-base/gpe-calculator/ChangeLog11
-rw-r--r--gpe-base/gpe-calculator/files/gpe-calculator-0.2-makefile-fix.patch47
-rw-r--r--gpe-base/gpe-calculator/gpe-calculator-0.2.ebuild20
-rw-r--r--gpe-base/gpe-calculator/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/gpe-base/gpe-calculator/ChangeLog b/gpe-base/gpe-calculator/ChangeLog
new file mode 100644
index 000000000000..4233e06a0751
--- /dev/null
+++ b/gpe-base/gpe-calculator/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for gpe-base/gpe-calculator
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gpe-base/gpe-calculator/ChangeLog,v 1.1 2009/07/06 19:31:03 miknix Exp $
+
+*gpe-calculator-0.2 (06 Jul 2009)
+
+ 06 Jul 2009; Angelo Arrifano <miknix@gentoo.org>
+ +files/gpe-calculator-0.2-makefile-fix.patch, +metadata.xml,
+ +gpe-calculator-0.2.ebuild:
+ Initial commit, imported from GPE overlay and based on #101393 .
+
diff --git a/gpe-base/gpe-calculator/files/gpe-calculator-0.2-makefile-fix.patch b/gpe-base/gpe-calculator/files/gpe-calculator-0.2-makefile-fix.patch
new file mode 100644
index 000000000000..07cb6f1778fc
--- /dev/null
+++ b/gpe-base/gpe-calculator/files/gpe-calculator-0.2-makefile-fix.patch
@@ -0,0 +1,47 @@
+diff -urNd ../gpe-calculator-0.2-r0/gpe-calculator-0.2/Makefile gpe-calculator-0.2/Makefile
+--- ../gpe-calculator-0.2-r0/gpe-calculator-0.2/Makefile 2004-08-03 04:24:09.000000000 +0100
++++ gpe-calculator-0.2/Makefile 2004-08-03 13:12:48.000000000 +0100
+@@ -9,17 +9,17 @@
+ GTKCFLAGS = `pkg-config --cflags gtk+-2.0` -DGTK_ENABLE_BROKEN
+ GTKLDFLAGS += `pkg-config --libs gtk+-2.0`
+
+-CPPFLAGS = -D_GNU_SOURCE
++PACKAGE_CPPFLAGS = -D_GNU_SOURCE
+ ifeq ($(DEBUG),yes)
+-CFLAGS += -O2 -g
+-LDFLAGS = -g #-lefence
++PACKAGE_CFLAGS += -O2 -g
++PACKAGE_LDFLAGS = -g #-lefence
+ else
+-CFLAGS += -Os -fomit-frame-pointer
++PACKAGE_CFLAGS += -Os -fomit-frame-pointer
+ endif
+-CFLAGS += -Wall $(GTKCFLAGS)
+-LDFLAGS += $(GTKLDFLAGS)
+-CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\" -DPACKAGE_DATA_DIR=\"$(PREFIX)/share\"
+-CFLAGS += -MD
++PACKAGE_CFLAGS += -Wall $(GTKCFLAGS)
++PACKAGE_LDFLAGS += $(GTKLDFLAGS)
++PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\" -DPACKAGE_DATA_DIR=\"$(PREFIX)/share\"
++PACKAGE_CFLAGS += -MD
+
+ .SUFFIXES: .d
+
+@@ -36,14 +36,15 @@
+ all: $(PACKAGE)
+
+ $(PACKAGE): $(OBJS)
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS)
+
+ install-program: all
+ install -D $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ install -D -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/$(PACKAGE).png
+ mkdir -p $(DESTDIR)$(PREFIX)/share/applications
+ install -m 644 $(PACKAGE).desktop $(DESTDIR)$(PREFIX)/share/applications
+- #strip $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+
+ clean:
+ rm -f $(PACKAGE) $(OBJS) $(DEPS)
diff --git a/gpe-base/gpe-calculator/gpe-calculator-0.2.ebuild b/gpe-base/gpe-calculator/gpe-calculator-0.2.ebuild
new file mode 100644
index 000000000000..8faa33c2d14c
--- /dev/null
+++ b/gpe-base/gpe-calculator/gpe-calculator-0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gpe-base/gpe-calculator/gpe-calculator-0.2.ebuild,v 1.1 2009/07/06 19:31:03 miknix Exp $
+
+inherit eutils gpe
+
+DESCRIPTION="A scientific calculator for the GPE Palmtop Environment"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="${IUSE}"
+RDEPEND="gpe-base/libgpewidget"
+
+src_unpack() {
+ gpe_src_unpack
+ epatch "${FILESDIR}/${P}-makefile-fix.patch"
+ # NLS is broken
+ sed -i -e 's;include $(BUILD)/Makefile.translation;;' Makefile
+}
+
diff --git a/gpe-base/gpe-calculator/metadata.xml b/gpe-base/gpe-calculator/metadata.xml
new file mode 100644
index 000000000000..cb08cb1d4795
--- /dev/null
+++ b/gpe-base/gpe-calculator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gpe</herd>
+<maintainer>
+ <email>gpe@gentoo.org</email>
+</maintainer>
+</pkgmetadata>