summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-13 21:01:55 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-13 21:01:55 +0000
commitb8e62bec13116c80d9bf883ca79ec4f790e9a3cf (patch)
treeb738da5f70f888469d4d200d1f1920ca768a0ebc /incoming
parentfixes/form changes (diff)
downloadgentoo-2-b8e62bec13116c80d9bf883ca79ec4f790e9a3cf.tar.gz
gentoo-2-b8e62bec13116c80d9bf883ca79ec4f790e9a3cf.tar.bz2
gentoo-2-b8e62bec13116c80d9bf883ca79ec4f790e9a3cf.zip
new incoming
Diffstat (limited to 'incoming')
-rw-r--r--incoming/apmd-3.0.1.ebuild52
-rw-r--r--incoming/gperiodic/files/gperiodic-1.3.2-gentoo.diff64
-rw-r--r--incoming/gperiodic/gperiodic-1.3.2.ebuild53
-rw-r--r--incoming/gtoaster-1.2_beta2.ebuild39
-rw-r--r--incoming/motion-2.6.3.ebuild26
-rw-r--r--incoming/postfix.diff11
6 files changed, 245 insertions, 0 deletions
diff --git a/incoming/apmd-3.0.1.ebuild b/incoming/apmd-3.0.1.ebuild
new file mode 100644
index 000000000000..564c441c1499
--- /dev/null
+++ b/incoming/apmd-3.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>
+# Submitted by Craig Joly <joly@ee.ualberta.ca>
+# /home/cvsroot/gentoo-x86/sys-apps/apmd/apmd-3.0.1.ebuild,v 1.4 2001/08/31 03:23:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Advanced Power Management Daemon"
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/a/apmd/apmd_3.0.1-1.tar.gz"
+HOMEPAGE="http://www.worldvisions.ca/~apenwarr/apmd/"
+
+DEPEND="X? ( virtual/x11 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:PREFIX=\/usr:PREFIX=\$\{DESTDIR\}\/usr:" Makefile | \
+ sed -e "s:APMD_PROXY_DIR\=\/etc:APMD_PROXY_DIR\=\$\{DESTDIR\}\/etc\/apm:" | \
+ sed -e "97d" | cat > Makefile
+ if [ -z "`use X`" ]; then
+ sed -e "/^EXES=/s/xapm//" -e "/install.*xapm/d" Makefile | \
+ cat > Makefile
+ fi
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodir /etc/apm/{event.d,suspend.d,resume.d}
+ insinto /etc/apm
+ insopts -m 0755
+ doins ${S}/debian/apmd_proxy
+
+ insinto /etc/rc.d/init.d
+ insopts -m 0755
+ doins ${FILESDIR}/apmd
+ doins ${FILESDIR}/svc-apmd
+
+ insinto /var/lib/supervise/services/apmd
+ insopts -m 0755
+ doins ${FILESDIR}/run
+
+ dodoc ANNOUNCE BUGS.apmsleep COPYING COPYING.LIB ChangeLog LSM \
+ README README.transfer
+}
diff --git a/incoming/gperiodic/files/gperiodic-1.3.2-gentoo.diff b/incoming/gperiodic/files/gperiodic-1.3.2-gentoo.diff
new file mode 100644
index 000000000000..4adc76ef093f
--- /dev/null
+++ b/incoming/gperiodic/files/gperiodic-1.3.2-gentoo.diff
@@ -0,0 +1,64 @@
+diff -urN gperiodic-1.3.2.orig/Makefile.am gperiodic-1.3.2/Makefile.am
+--- gperiodic-1.3.2.orig/Makefile.am Tue Aug 28 02:04:50 2001
++++ gperiodic-1.3.2/Makefile.am Wed Oct 10 22:22:17 2001
+@@ -1,4 +1,4 @@
+-CFLAGS=-DVERSION="1.2.6a"
++CFLAGS=-DVERSION="1.3.2"
+ SUBDIRS = intl po src
+
+ EXTRA_DIST = Changes
+diff -urN gperiodic-1.3.2.orig/Makefile.in gperiodic-1.3.2/Makefile.in
+--- gperiodic-1.3.2.orig/Makefile.in Tue Aug 28 02:04:50 2001
++++ gperiodic-1.3.2/Makefile.in Wed Oct 10 22:21:28 2001
+@@ -92,7 +92,7 @@
+ YACC = @YACC@
+ l = @l@
+
+-CFLAGS = -DVERSION="1.2.6a"
++CFLAGS = -DVERSION="1.3.2"
+ SUBDIRS = intl po src
+
+ EXTRA_DIST = Changes
+diff -urN gperiodic-1.3.2.orig/configure gperiodic-1.3.2/configure
+--- gperiodic-1.3.2.orig/configure Tue Aug 28 02:04:50 2001
++++ gperiodic-1.3.2/configure Wed Oct 10 22:25:18 2001
+@@ -844,7 +844,7 @@
+ SET_MAKE="MAKE=${MAKE-make}"
+ fi
+
+-AM_PROG_LEX
++#AM_PROG_LEX
+ for ac_prog in 'bison -y' byacc
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+diff -urN gperiodic-1.3.2.orig/configure.in gperiodic-1.3.2/configure.in
+--- gperiodic-1.3.2.orig/configure.in Tue Aug 28 02:04:50 2001
++++ gperiodic-1.3.2/configure.in Wed Oct 10 21:44:05 2001
+@@ -2,13 +2,13 @@
+ AC_INIT(include/gperiodic.h)
+
+ AM_CONFIG_HEADER(config.h)
+-AM_INIT_AUTOMAKE(gperiodic, 1.2.6a)
++AM_INIT_AUTOMAKE(gperiodic, 1.3.2)
+
+ AM_MAINTAINER_MODE
+
+ dnl Checks for programs.
+ AC_PROG_MAKE_SET
+-AM_PROG_LEX
++dnl AM_PROG_LEX
+ AC_PROG_YACC
+ AC_ISC_POSIX
+
+diff -urN gperiodic-1.3.2.orig/src/Makefile.in gperiodic-1.3.2/src/Makefile.in
+--- gperiodic-1.3.2.orig/src/Makefile.in Tue Aug 28 02:04:51 2001
++++ gperiodic-1.3.2/src/Makefile.in Wed Oct 10 21:42:03 2001
+@@ -95,7 +95,7 @@
+ bin_PROGRAMS = gperiodic
+
+ gperiodic_SOURCES = gperiodic.c cmdline_interface.c gparser.y gplexer.l gpdata.c
+-gperiodic_LDADD = -lreadline -ltermcap
++gperiodic_LDADD = -lreadline -lncurses
+
+ INCLUDES = -I$(top_srcdir)/include -DGPERIODIC_LOCALE_DIR=\"$(datadir)/locale\"
+
diff --git a/incoming/gperiodic/gperiodic-1.3.2.ebuild b/incoming/gperiodic/gperiodic-1.3.2.ebuild
new file mode 100644
index 000000000000..8ea096001959
--- /dev/null
+++ b/incoming/gperiodic/gperiodic-1.3.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GPeriodic is a periodic table application for Linux."
+
+SRC_URI="ftp://ftp.seul.org/pub/gperiodic/${P}.tar.gz"
+
+HOMEPAGE="http://gperiodic.seul.org/"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=x11-libs/gtk+-1.2.1
+ nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+#Fix version number,comment out non-working lex inquiry
+# to eliminate superfluous config error, and use ncurses for termcap
+ patch -p1 < ${FILESDIR}/${P}-gentoo.diff || die
+}
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man \
+ --prefix=/usr --host=${CHOST} ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+ doman man/gperiodic.1
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+}
+
diff --git a/incoming/gtoaster-1.2_beta2.ebuild b/incoming/gtoaster-1.2_beta2.ebuild
new file mode 100644
index 000000000000..db3dc059dba5
--- /dev/null
+++ b/incoming/gtoaster-1.2_beta2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Claes Nästén <pekdon@gmx.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+P=gtoaster1.0Beta2
+PV=1.0beta2
+S=${WORKDIR}/gtoaster
+DESCRIPTION="GTK+ Frontend for cdrecord"
+SRC_URI="http://gnometoaster.rulez.org/archive/${P}.tgz"
+HOMEPAGE="http://gnometoaster.rulez.org/"
+
+DEPEND=">=x11-libs/gtk+-1.2
+ gnome? ( >=gnome-base/gnome-core-1.2.2.1 )
+ esd? ( >=media-sound/esound-0.2.22 )"
+
+RDEPEND=">=app-cdr/cdrecord-1.9
+ >=media-sound/sox-12
+ >=media-sound/mpg123-0.59"
+
+src_compile() {
+ local myconf
+ use gnome && myconf="$myconf --with-gnome"
+ use gnome || myconf="$myconf --without-gnome"
+ use esd && myconf="$myconf --with-esd"
+ use esd || myconf="$myconf --without-esd"
+ use oss && myconf="$myconf --with-oss"
+ use oss || myconf="$myconf --without-oss"
+
+
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} $myconf || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ dodoc Changelog* COPYING INSTALL NEWS README TODO
+}
+
diff --git a/incoming/motion-2.6.3.ebuild b/incoming/motion-2.6.3.ebuild
new file mode 100644
index 000000000000..cb37ed16803c
--- /dev/null
+++ b/incoming/motion-2.6.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jens Blaesche <mr.big@pc-trouble.de>
+
+S=${WORKDIR}/${P}
+A=${P}.tar.gz
+DESCRIPTION="Motion is a nice tool to use a v4l-device as a supervision-camera."
+SRC_URI="http://motion.technolust.cx/download/${A}"
+HOMEPAGE="http://motion.technolust.cx"
+
+DEPEND=">=media-video/mpeg-tools-1.5"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr
+ make || die
+}
+
+src_install () {
+
+ exeinto /usr/bin
+ doexe motion
+ insinto /etc
+ doins motion.conf
+ dodoc CREDITS COPYING CHANGELOG INSTALL README TODO
+ doman ${S}/motion.1
+}
diff --git a/incoming/postfix.diff b/incoming/postfix.diff
new file mode 100644
index 000000000000..989d59fa5182
--- /dev/null
+++ b/incoming/postfix.diff
@@ -0,0 +1,11 @@
+--- postfix-20010228.2-r6.ebuild Mon Sep 17 19:50:42 2001
++++ postfix-20010228.5.ebuild Fri Oct 5 02:24:21 2001
+@@ -3,7 +3,7 @@
+ # Author Jerry Alexandratos <jerry@gentoo.org>
+ # /home/cvsroot/gentoo-x86/net-mail/postfix/postfix-20010228.2-r6.ebuild,v 1.1 2001/09/18 00:50:42 agriffis Exp
+
+-P=${PN}-20010228-pl02
++P=${PN}-20010228-pl05
+ A=${P}.tar.gz
+ S=${WORKDIR}/${P}
+ DESCRIPTION="A fast and secure drop-in replacement for sendmail"