summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-30 11:15:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-30 11:15:14 +0000
commit827600348a0f4dcf12183088d5f095eb44c169af (patch)
treef9316dc640bfd95e571928172adf9c395555910b /kde-apps
parentOops (diff)
downloadgentoo-2-827600348a0f4dcf12183088d5f095eb44c169af.tar.gz
gentoo-2-827600348a0f4dcf12183088d5f095eb44c169af.tar.bz2
gentoo-2-827600348a0f4dcf12183088d5f095eb44c169af.zip
oops again
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/koffice/koffice-1.1_beta1.ebuild50
-rw-r--r--kde-apps/koffice/koffice-2.0.1.ebuild29
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-apps/koffice/koffice-1.1_beta1.ebuild b/kde-apps/koffice/koffice-1.1_beta1.ebuild
new file mode 100644
index 000000000000..d707071e77b1
--- /dev/null
+++ b/kde-apps/koffice/koffice-1.1_beta1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-apps/koffice/koffice-1.1_beta1.ebuild,v 1.4 2001/04/30 11:15:14 achim Exp $
+
+P=${PN}-1.1-beta1
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="KDE ${PV} - KOffice"
+SRC_PATH="kde/unstable/${P}/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=kde-base/kdelibs-2.1.1
+ >=dev-lang/python-2.0-r2"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+ try ./configure --prefix=$KDEDIR --host=${CHOST} \
+ --with-qt-dir=$QTBASE
+
+# if [ "`use readline`" ]
+# then
+# # I use sed to patch a makefile to compile with python
+# for i in connector text zoom selector
+# do
+# cd ${S}/kivio/plugins/kivio${i}tool
+# cp Makefile Makefile.org
+# sed -e "s:^LDFLAGS =.*:LDFLAGS = -lreadline -lncurses:" Makefile.orig > Makefile
+# done
+# fi
+ cd ${S}
+ if [ "`use readline`" ]
+ then
+ try make LIBPYTHON=\"-lpython2.0 -lm -lutil -ldl -lz -lreadline -lncurses\"
+ else
+ try make
+ fi
+
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc ChangeLog COPYING AUTHORS NEWS README
+}
+
diff --git a/kde-apps/koffice/koffice-2.0.1.ebuild b/kde-apps/koffice/koffice-2.0.1.ebuild
new file mode 100644
index 000000000000..d193a8702884
--- /dev/null
+++ b/kde-apps/koffice/koffice-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-apps/koffice/koffice-2.0.1.ebuild,v 1.5 2001/04/30 11:15:14 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="KDE ${PV} - KOffice"
+SRC_PATH="kde/stable/${PV}/distribution/tar/generic/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=kde-base/kdelibs-${PV}"
+RDEPEND=$DEPEND
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+ try ./configure --prefix=$KDEDIR --host=${CHOST} \
+ --with-qt-dir=$QTBASE
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc ChangeLog COPYING AUTHORS NEWS README
+}
+