summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-05-08 17:26:39 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-05-08 17:26:39 +0000
commit3d946aae50fb4483e702dd9d55dd60cd1bb43315 (patch)
treed12117411edaa852d11088d2ec0eca40e2660e77 /kde-base/ark
parentsupport db-4.8 and db-4.7 as well (diff)
downloadgentoo-2-3d946aae50fb4483e702dd9d55dd60cd1bb43315.tar.gz
gentoo-2-3d946aae50fb4483e702dd9d55dd60cd1bb43315.tar.bz2
gentoo-2-3d946aae50fb4483e702dd9d55dd60cd1bb43315.zip
Added patch from upstream bug (https://bugs.kde.org/show_bug.cgi?id=271553).
Fixes bug 366311. (Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog14
-rw-r--r--kde-base/ark/ark-4.4.5-r2.ebuild35
-rw-r--r--kde-base/ark/ark-4.6.2-r1.ebuild40
-rw-r--r--kde-base/ark/ark-4.6.3-r1.ebuild40
-rw-r--r--kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch25
-rw-r--r--kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch32
6 files changed, 185 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index beb44057c72d..81d02d539b07 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.180 2011/05/07 10:47:42 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.181 2011/05/08 17:26:39 jmbsvicetto Exp $
+
+*ark-4.6.3-r1 (08 May 2011)
+*ark-4.6.2-r1 (08 May 2011)
+*ark-4.4.5-r2 (08 May 2011)
+
+ 08 May 2011; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +ark-4.4.5-r2.ebuild,
+ +files/ark-4.4.5-detect-libarchive-in-proper-place.patch,
+ +ark-4.6.2-r1.ebuild, +ark-4.6.3-r1.ebuild,
+ +files/ark-detect-libarchive-in-proper-place.patch:
+ Added patch from upstream bug (https://bugs.kde.org/show_bug.cgi?id=271553).
+ Fixes bug 366311.
*ark-4.6.3 (07 May 2011)
diff --git a/kde-base/ark/ark-4.4.5-r2.ebuild b/kde-base/ark/ark-4.4.5-r2.ebuild
new file mode 100644
index 000000000000..8ed5ff08138c
--- /dev/null
+++ b/kde-base/ark/ark-4.4.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.4.5-r2.ebuild,v 1.1 2011/05/08 17:26:39 jmbsvicetto Exp $
+
+EAPI="3"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug +handbook lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+"
+RDEPEND="${DEPEND}"
+
+# detect-libarchive patch - https://bugs.kde.org/show_bug.cgi?id=271553
+PATCHES=(
+ "${FILESDIR}/${P}-cli7zip.patch"
+ "${FILESDIR}/${P}-detect-libarchive-in-proper-place.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-meta_src_configure
+}
diff --git a/kde-base/ark/ark-4.6.2-r1.ebuild b/kde-base/ark/ark-4.6.2-r1.ebuild
new file mode 100644
index 000000000000..1ff56bcc9314
--- /dev/null
+++ b/kde-base/ark/ark-4.6.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.6.2-r1.ebuild,v 1.1 2011/05/08 17:26:39 jmbsvicetto Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+"
+RDEPEND="${DEPEND}"
+
+# detect-libarchive patch - https://bugs.kde.org/show_bug.cgi?id=271553
+PATCHES=(
+ "${FILESDIR}/${PN}-detect-libarchive-in-proper-place.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}
diff --git a/kde-base/ark/ark-4.6.3-r1.ebuild b/kde-base/ark/ark-4.6.3-r1.ebuild
new file mode 100644
index 000000000000..ae2d2562c3aa
--- /dev/null
+++ b/kde-base/ark/ark-4.6.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.6.3-r1.ebuild,v 1.1 2011/05/08 17:26:39 jmbsvicetto Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+"
+RDEPEND="${DEPEND}"
+
+# detect-libarchive patch - https://bugs.kde.org/show_bug.cgi?id=271553
+PATCHES=(
+ "${FILESDIR}/${PN}-detect-libarchive-in-proper-place.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}
diff --git a/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch b/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch
new file mode 100644
index 000000000000..452830f83a1c
--- /dev/null
+++ b/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch
@@ -0,0 +1,25 @@
+diff --git a/ark/CMakeLists.txt b/ark/CMakeLists.txt
+index 6ea72bb..85c5ce0 100644
+--- a/ark/CMakeLists.txt
++++ b/ark/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ project(ark)
+
++macro_optional_find_package(LibArchive)
++macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
++
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+ add_subdirectory(part)
+diff --git a/ark/plugins/CMakeLists.txt b/ark/plugins/CMakeLists.txt
+index a8c4e44..e3cb9ec 100644
+--- a/ark/plugins/CMakeLists.txt
++++ b/ark/plugins/CMakeLists.txt
+@@ -1,7 +1,3 @@
+-macro_optional_find_package(LibArchive)
+-
+-macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://people.freebsd.org/~kientzle/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark. Make sure it is compiled with gzip support.")
+-
+ if (LIBARCHIVE_FOUND)
+ if( NOT HAVE_LIBARCHIVE_LZMA_SUPPORT OR NOT HAVE_LIBARCHIVE_XZ_SUPPORT )
+ message(STATUS "Your libarchive does not have support for lzma and/or xz archives. libarchive >= 2.7.0 is recommended.")
diff --git a/kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch b/kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch
new file mode 100644
index 000000000000..0a7bd5085820
--- /dev/null
+++ b/kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch
@@ -0,0 +1,32 @@
+diff --git a/ark/CMakeLists.txt b/ark/CMakeLists.txt
+index 6ea72bb..85c5ce0 100644
+--- a/ark/CMakeLists.txt
++++ b/ark/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ project(ark)
+
++macro_optional_find_package(LibArchive)
++macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
++
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+ add_subdirectory(part)
+diff --git a/ark/plugins/CMakeLists.txt b/ark/plugins/CMakeLists.txt
+index a8c4e44..e3cb9ec 100644
+--- a/ark/plugins/CMakeLists.txt
++++ b/ark/plugins/CMakeLists.txt
+@@ -1,5 +1,3 @@
+-macro_optional_find_package(LibArchive)
+-
+ if (LIBARCHIVE_FOUND)
+ if( HAVE_LIBARCHIVE_READ_DISK_API )
+ if( NOT HAVE_LIBARCHIVE_LZMA_SUPPORT OR NOT HAVE_LIBARCHIVE_XZ_SUPPORT )
+@@ -15,8 +13,6 @@ if (LIBARCHIVE_FOUND)
+ endif( HAVE_LIBARCHIVE_READ_DISK_API )
+ endif (LIBARCHIVE_FOUND)
+
+-macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
+-
+ add_subdirectory( clirarplugin )
+ add_subdirectory( cli7zplugin )
+ add_subdirectory( clizipplugin )