summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
committerJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
commitad239490ed9eef8b7e06727b919d4593f51667ae (patch)
tree86688474b00c8427904e72d675cbe3d82b38d1c2 /kde-base/ark
parentVersion bump. (diff)
downloadgentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.gz
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.bz2
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.zip
Version bump KDE SC 4.13.1
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.13.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index c3cc5c640623..a175789e9453 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.329 2014/05/08 10:31:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.330 2014/05/13 17:43:41 johu Exp $
+
+*ark-4.13.1 (13 May 2014)
+
+ 13 May 2014; Johannes Huber <johu@gentoo.org> +ark-4.13.1.ebuild:
+ Version bump KDE SC 4.13.1
08 May 2014; Agostino Sarubbo <ago@gentoo.org> -ark-4.11.5.ebuild:
Remove old
diff --git a/kde-base/ark/ark-4.13.1.ebuild b/kde-base/ark/ark-4.13.1.ebuild
new file mode 100644
index 000000000000..26f9fc44415d
--- /dev/null
+++ b/kde-base/ark/ark-4.13.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.13.1.ebuild,v 1.1 2014/05/13 17:43:41 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="http://www.kde.org/applications/utilities/ark
+http://utils.kde.org/projects/ark"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1:=[bzip2?,lzma?,zlib] )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# dbus problem
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version app-arch/rar ; then
+ elog "For creating rar archives, install app-arch/rar"
+ fi
+}