summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
commitc106175041331c114244227a14b1c3242fe799ee (patch)
treee16e2d4ee461b8ac893f1113d86a29e0b20658b8 /kde-base/ark
parentAdd patch to support >=gtk-2.24.0. #460714 (diff)
downloadgentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.gz
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.bz2
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.zip
Version bump KDE SC 4.10.2
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.10.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index a7605e31e7c7..84e91e8747ed 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.264 2013/04/02 20:51:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.265 2013/04/06 00:04:23 dilfridge Exp $
+
+*ark-4.10.2 (05 Apr 2013)
+
+ 05 Apr 2013; Andreas K. Huettel <dilfridge@gentoo.org> +ark-4.10.2.ebuild:
+ Version bump KDE SC 4.10.2
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> ark-4.10.1.ebuild:
Stable for ppc64, wrt to bug #462890
diff --git a/kde-base/ark/ark-4.10.2.ebuild b/kde-base/ark/ark-4.10.2.ebuild
new file mode 100644
index 000000000000..2d954cd9b6df
--- /dev/null
+++ b/kde-base/ark/ark-4.10.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.10.2.ebuild,v 1.1 2013/04/06 00:04:23 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1:=[bzip2?,lzma?,zlib] )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# dbus problem
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version app-arch/rar ; then
+ elog "For creating rar archives, install app-arch/rar"
+ fi
+}