summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-07-20 20:45:16 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-07-20 20:45:16 +0000
commit3392c41bb33d02f62d459b6aae21b34f2f39c8d8 (patch)
treebafeecae8c6a275fd78348ca08a4e6e5a3c2f1c1 /kde-base/arts
parentStabilizing (diff)
downloadgentoo-2-3392c41bb33d02f62d459b6aae21b34f2f39c8d8.tar.gz
gentoo-2-3392c41bb33d02f62d459b6aae21b34f2f39c8d8.tar.bz2
gentoo-2-3392c41bb33d02f62d459b6aae21b34f2f39c8d8.zip
New version for upcoming release of kde 3.1.3
Diffstat (limited to 'kde-base/arts')
-rw-r--r--kde-base/arts/ChangeLog9
-rw-r--r--kde-base/arts/Manifest6
-rw-r--r--kde-base/arts/arts-1.1.3.ebuild81
-rw-r--r--kde-base/arts/files/digest-arts-1.1.31
4 files changed, 94 insertions, 3 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index a792bd16cc53..d756983fb9cf 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.50 2003/07/19 19:47:37 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.51 2003/07/20 20:44:57 caleb Exp $
+
+*arts-1.1.3 (20 Jul 2003)
+
+ 20 Jul 2003; Caleb Tennis <caleb@gentoo.org> arts-1.1.3.ebuild:
+ Version bump of ebuild for kde 3.1.3. Commented out the arts and
+ oggvorbis patch support as it causes it not to compile (at least on my
+ machine). Will require more testing.
19 Jul 2003; Nick Hadaway <raker@gentoo.org> arts-1.1.2-r1.ebuild:
Changed mads dep back to media-sound/mad
diff --git a/kde-base/arts/Manifest b/kde-base/arts/Manifest
index 94f8199a2802..926764a6c47f 100644
--- a/kde-base/arts/Manifest
+++ b/kde-base/arts/Manifest
@@ -1,13 +1,15 @@
MD5 28a643d6bb6a22518803e2bc7229794f arts-1.0.4-r1.ebuild 1040
MD5 aa34526bbb65b5e284d92b674d35e5f0 arts-1.1.1.ebuild 1871
+MD5 499c51507644a07d4662f42890c7b201 arts-1.1.3.ebuild 2781
MD5 e419d02f1b1d63659351f826d353442b arts-1.0.5b.ebuild 1439
MD5 1eb56b176533543786305da336b6b7f3 arts-1.1.2.ebuild 2749
-MD5 aa91667b84ed6ae122df8131b1646777 arts-1.1.2-r1.ebuild 2748
-MD5 afc1e27122168e224a0da73f3beeca62 ChangeLog 7025
+MD5 eb10eca6f21dc60a048117a03889a584 arts-1.1.2-r1.ebuild 2748
+MD5 64ba4f0303a99aad4c587ea1f0408a37 ChangeLog 7302
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
MD5 9ffc978b18c6e1ad49a0c7eec49074f6 files/optional-deps.diff 3154
MD5 0618185a5569820b71b70e635ac9cd2a files/digest-arts-1.1.1 63
MD5 8a2eb6e84c39661304e7c3c395ecb5b5 files/digest-arts-1.1.2 63
+MD5 a501dd1ce9294fceb81a87c056db568f files/digest-arts-1.1.3 63
MD5 783f52e41abb732466bec517c6ff1ae1 files/digest-arts-1.0.5b 200
MD5 1b00ca71ff1ea0b5ed8387a0d5f9020d files/digest-arts-1.0.4-r1 64
MD5 8a2eb6e84c39661304e7c3c395ecb5b5 files/digest-arts-1.1.2-r1 63
diff --git a/kde-base/arts/arts-1.1.3.ebuild b/kde-base/arts/arts-1.1.3.ebuild
new file mode 100644
index 000000000000..69680cde3131
--- /dev/null
+++ b/kde-base/arts/arts-1.1.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.3.ebuild,v 1.1 2003/07/20 20:44:57 caleb Exp $
+inherit kde-base flag-o-matic
+
+IUSE="alsa oggvorbis artswrappersuid mad"
+
+set-kdedir 3.1
+need-qt 3.1.0
+
+SRC_URI="mirror://kde/stable/3.1.3/src/${P}.tar.bz2"
+HOMEPAGE="http://multimedia.kde.org"
+DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+newdepend "alsa? ( media-libs/alsa-lib )
+ oggvorbis? ( media-libs/libvorbis media-libs/libogg )
+ mad? ( media-libs/libmad media-libs/libid3tag )
+ media-libs/audiofile
+ >=dev-libs/glib-2"
+
+if [ "${COMPILER}" == "gcc3" ]; then
+ # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+ # these.. Even starting a compile shuts down the arts server
+ filter-flags "-fomit-frame-pointer -fstrength-reduce"
+fi
+
+#fix bug 13453
+filter-flags "-foptimize-sibling-calls"
+
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use oggvorbis || myconf="$myconf --disable-vorbis"
+use mad || myconf="$myconf --disable-libmad"
+
+# patch to configure.in.in that makes the vorbis, libmad deps optional
+# has no version number in its filename because it's the same for all
+# arts versions - the patched file hasn't changed in a year's time
+#PATCHES="$FILESDIR/optional-deps.diff"
+PATCHES=""
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/soundserver
+ # for the configure.in.in patch, for some reason it's not automatically picked up
+ #rm $S/configure
+}
+
+src_install() {
+ kde_src_install
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+ # moved here from kdelibs so that when arts is installed
+ # without kdelibs it's still in the path.
+ dodir /etc/env.d
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/49kdepaths-3.1.2 # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/56kdedir-3.1.2 # number goes up with version upgrade
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod +s ${D}/${PREFIX}/bin/artswrapper
+
+}
+
+pkg_postinst() {
+
+if [ -z "`use artswrappersuid`" ]; then
+ einfo "Run chmod +s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ einfo "and so avoid possible skips in sound. However, on untrusted systems this"
+ einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ einfo "priority, and so is off by default. See bug #7883."
+ einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+fi
+
+}
diff --git a/kde-base/arts/files/digest-arts-1.1.3 b/kde-base/arts/files/digest-arts-1.1.3
new file mode 100644
index 000000000000..3b9d6a06a2cf
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-1.1.3
@@ -0,0 +1 @@
+MD5 f04eb6ef387d63741561ab6623696322 arts-1.1.3.tar.bz2 986366