summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 22:29:30 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 22:29:30 +0000
commit8bacbefec0a4c62def0466a28fad67700df8426b (patch)
tree3e522b4c7340c64ae09da65902f54e5270d70a32 /kde-base/arts
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-8bacbefec0a4c62def0466a28fad67700df8426b.tar.gz
gentoo-2-8bacbefec0a4c62def0466a28fad67700df8426b.tar.bz2
gentoo-2-8bacbefec0a4c62def0466a28fad67700df8426b.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/arts')
-rw-r--r--kde-base/arts/ChangeLog8
-rw-r--r--kde-base/arts/arts-3.5.9.ebuild91
-rw-r--r--kde-base/arts/files/arts-1.5.5-gcc4.3-build-fix.diff10
3 files changed, 108 insertions, 1 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index 631289abc3aa..6cb65b1d15e3 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.260 2008/02/17 03:05:27 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.261 2008/02/20 22:29:29 philantrop Exp $
+
+*arts-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/arts-1.5.5-gcc4.3-build-fix.diff, +arts-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
17 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/arts-1.5.5-gcc4.3-build-fix.diff, -arts-3.5.5.ebuild:
diff --git a/kde-base/arts/arts-3.5.9.ebuild b/kde-base/arts/arts-3.5.9.ebuild
new file mode 100644
index 000000000000..c7c27fc15b87
--- /dev/null
+++ b/kde-base/arts/arts-3.5.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-3.5.9.ebuild,v 1.1 2008/02/20 22:29:29 philantrop Exp $
+
+EAPI="1"
+inherit kde flag-o-matic eutils versionator
+set-kdedir 3.5
+
+MY_PV="1.$(get_version_component_range 2-3)"
+S=${WORKDIR}/${PN}-${MY_PV}
+
+RESTRICT="test"
+
+DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://multimedia.kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/${PN}-${MY_PV}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="3.5"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa esd artswrappersuid jack mp3 nas vorbis"
+
+RDEPEND="$(qt_min_version 3.3)
+ >=dev-libs/glib-2
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg
+ media-libs/libvorbis )
+ esd? ( media-sound/esound )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90 )
+ mp3? ( media-libs/libmad )
+ nas? ( media-libs/nas )
+ media-libs/audiofile"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/arts-1.5.0-bindnow.patch
+ ${FILESDIR}/arts-1.5.4-multilib.patch"
+
+src_unpack() {
+ kde_src_unpack
+
+ sed -i -e "s:GENTOO_LIB64:$(get_abi_LIBDIR amd64):" \
+ -e "s:GENTOO_LIB32:$(get_abi_LIBDIR x86):" artsc/artsdsp.in \
+ || die "multilib-sed failed"
+
+ # Alternative to arts-1.4-mcopidl.patch, make sure that flags are supported
+ # before trying to use them, for non-GCC, vanilla GCC or GCC 4.1 compilers
+ local nosspflags
+
+ nosspflags="$(test-flags -fno-stack-protector -fno-stack-protector-all)"
+ sed -i -e "s:KDE_CXXFLAGS =\(.*\):KDE_CXXFLAGS = \1 ${nosspflags}:" \
+ "${S}/mcopidl/Makefile.am"
+
+ # Fix libao/gaim problems with aRTs. See bug #116290.
+ epatch "${FILESDIR}/arts-1.5.0-check_tmp_dir.patch"
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ myconf="$(use_enable alsa) $(use_enable vorbis)
+ $(use_enable mp3 libmad) $(use_with jack)
+ $(use_with esd) $(use_with nas)
+ --with-audiofile --without-mas"
+
+ #fix bug 13453
+ filter-flags -foptimize-sibling-calls
+
+ # breaks otherwise <gustavoz>
+ use sparc && export CFLAGS="-O1" && export CXXFLAGS="-O1"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${PREFIX}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ elog "and so avoid possible skips in sound. However, on untrusted systems this"
+ elog "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See bug #7883."
+ elog "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/kde-base/arts/files/arts-1.5.5-gcc4.3-build-fix.diff b/kde-base/arts/files/arts-1.5.5-gcc4.3-build-fix.diff
new file mode 100644
index 000000000000..7087e226861b
--- /dev/null
+++ b/kde-base/arts/files/arts-1.5.5-gcc4.3-build-fix.diff
@@ -0,0 +1,10 @@
+--- arts-1.5.5/mcopidl/mcopidl.cc 2005-09-10 10:13:31.000000000 +0200
++++ arts-1.5.7/mcopidl/mcopidl.cc 2007-05-14 09:36:40.000000000 +0200
+@@ -23,6 +23,7 @@
+
+ */
+
++#include <cstdlib>
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>