summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:15:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:15:54 +0000
commit95de75a2a1feb7671ac547515dc80e44f2a1a513 (patch)
tree637ca149e00fd7929496a77a78a8aeb74bfdb8fc /kde-base/cantor
parent[kde-base/khotkeys] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-95de75a2a1feb7671ac547515dc80e44f2a1a513.tar.gz
gentoo-2-95de75a2a1feb7671ac547515dc80e44f2a1a513.tar.bz2
gentoo-2-95de75a2a1feb7671ac547515dc80e44f2a1a513.zip
[kde-base/cantor] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog9
-rw-r--r--kde-base/cantor/cantor-4.4.0.ebuild43
2 files changed, 52 insertions, 0 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
new file mode 100644
index 000000000000..48b1977a9f6b
--- /dev/null
+++ b/kde-base/cantor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for kde-base/cantor
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.1 2010/02/09 00:15:54 alexxy Exp $
+
+*cantor-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +cantor-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
+
diff --git a/kde-base/cantor/cantor-4.4.0.ebuild b/kde-base/cantor/cantor-4.4.0.ebuild
new file mode 100644
index 000000000000..09545b2ffc25
--- /dev/null
+++ b/kde-base/cantor/cantor-4.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.4.0.ebuild,v 1.1 2010/02/09 00:15:54 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +handbook ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs+="
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ "
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}