summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
commita7d39b161d3ea87618db515020379fc2be385858 (patch)
tree3fd47e295f81d71610e045a95b9b7a70e5373756 /kde-base/cantor
parentAdd systemd support (#466084) (diff)
downloadgentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.gz
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.bz2
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.zip
Bump KDE to 4.1.1
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.11.1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index 98dc528bee8c..d90c3f29b230 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.135 2013/08/14 20:24:09 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.136 2013/09/03 19:04:32 creffett Exp $
+
+*cantor-4.11.1 (03 Sep 2013)
+
+ 03 Sep 2013; Chris Reffett <creffett@gentoo.org> +cantor-4.11.1.ebuild:
+ Bump KDE to 4.1.1
*cantor-4.11.0 (14 Aug 2013)
diff --git a/kde-base/cantor/cantor-4.11.1.ebuild b/kde-base/cantor/cantor-4.11.1.ebuild
new file mode 100644
index 000000000000..cd0749cca8eb
--- /dev/null
+++ b/kde-base/cantor/cantor-4.11.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.11.1.ebuild,v 1.1 2013/09/03 19:04:32 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+HOMEPAGE="http://www.kde.org/applications/education/cantor http://edu.kde.org/cantor"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="analitza debug postscript qalculate +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ analitza? ( $(add_kdebase_dep analitza) )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate
+ )
+ postscript? ( app-text/libspectre )
+ R? ( dev-lang/R )
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with analitza)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with R)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use analitza && ! use qalculate && ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'analitza', 'qalculate' or 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}