summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
commit34c78a7dee48cc1df1e35264ea7e2c682926f487 (patch)
treef8ccbed0c1c5eda4ad6795fb2d3a688f91bb62e1 /kde-base/dolphin
parentMark stable for amd64/x86 per bug #415255 (diff)
downloadgentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.gz
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.bz2
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.zip
KDE 4.8.4 version bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.8.4.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 3f6e8e4d2fe0..313877382150 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.139 2012/05/24 11:37:53 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.140 2012/06/21 21:55:05 dilfridge Exp $
+
+*dolphin-4.8.4 (21 Jun 2012)
+
+ 21 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org> +dolphin-4.8.4.ebuild:
+ Version bump KDE SC 4.8.4
24 May 2012; Johannes Huber <johu@gentoo.org> -dolphin-4.8.1.ebuild:
Remove KDE SC 4.8.1
diff --git a/kde-base/dolphin/dolphin-4.8.4.ebuild b/kde-base/dolphin/dolphin-4.8.4.ebuild
new file mode 100644
index 000000000000..54e99b090b3c
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.8.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.8.4.ebuild,v 1.1 2012/06/21 21:55:05 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( dev-libs/shared-desktop-ontologies )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ echo
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ echo
+}