summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
commitc106175041331c114244227a14b1c3242fe799ee (patch)
treee16e2d4ee461b8ac893f1113d86a29e0b20658b8 /kde-base/dolphin
parentAdd patch to support >=gtk-2.24.0. #460714 (diff)
downloadgentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.gz
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.bz2
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.zip
Version bump KDE SC 4.10.2
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog8
-rw-r--r--kde-base/dolphin/dolphin-4.10.2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 5ac642d287a2..38d2633f7bb1 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.176 2013/04/02 20:51:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.177 2013/04/06 00:05:06 dilfridge Exp $
+
+*dolphin-4.10.2 (05 Apr 2013)
+
+ 05 Apr 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +dolphin-4.10.2.ebuild:
+ Version bump KDE SC 4.10.2
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> dolphin-4.10.1.ebuild:
Stable for ppc64, wrt to bug #462890
diff --git a/kde-base/dolphin/dolphin-4.10.2.ebuild b/kde-base/dolphin/dolphin-4.10.2.ebuild
new file mode 100644
index 000000000000..7265ee3dfc54
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.10.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.10.2.ebuild,v 1.1 2013/04/06 00:05:06 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? (
+ >=dev-libs/shared-desktop-ontologies-0.10.0
+ dev-libs/soprano
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep nepomuk-widgets)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop NepomukCore)
+ $(cmake-utils_use_with semantic-desktop NepomukWidgets)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version media-gfx/icoutils ; then
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ fi
+}