summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:15:12 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:15:12 +0000
commitcdd36415194bcddc3bc38d87becef34822bf29ba (patch)
tree36b4b22939761a13acbdb971ab3125d8c745e5d2 /kde-base/dolphin
parentVersion bump KDE 4.4.3 (diff)
downloadgentoo-2-cdd36415194bcddc3bc38d87becef34822bf29ba.tar.gz
gentoo-2-cdd36415194bcddc3bc38d87becef34822bf29ba.tar.bz2
gentoo-2-cdd36415194bcddc3bc38d87becef34822bf29ba.zip
Version bump KDE 4.4.3
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.4.3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 586323b89c53..9d99bf886ada 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.70 2010/03/31 22:00:37 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.71 2010/05/03 20:15:12 alexxy Exp $
+
+*dolphin-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -dolphin-4.3.4.ebuild,
-dolphin-4.4.0.ebuild:
diff --git a/kde-base/dolphin/dolphin-4.4.3.ebuild b/kde-base/dolphin/dolphin-4.4.3.ebuild
new file mode 100644
index 000000000000..3b1a7f47f3e4
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.4.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.4.3.ebuild,v 1.1 2010/05/03 20:15:12 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook semantic-desktop subversion thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+ subversion? (
+ dev-util/subversion
+ $(add_kdebase_dep kompare)
+ )
+"
+PDEPEND="
+ thumbnail? ( $(add_kdebase_dep mplayerthumbs) )
+"
+
+KMLOADLIBS="libkonq"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use subversion; then
+ sed -e '/install(.*fileviewsvnplugin.*)/s/^/#DONOTINSTALL /g' \
+ -i dolphin/src/CMakeLists.txt || die 'failed to disable subversion plugin'
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}