summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
commit14c988d01f8c84ab2bd2faa3c01c646602dc1692 (patch)
tree4b095bcf239f3426af85e14e94933b79e8588042 /kde-base/kalgebra/kalgebra-4.12.1.ebuild
parentCleanup. (diff)
downloadgentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.gz
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.bz2
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.zip
Version bump KDE SC 4.12.1
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kalgebra/kalgebra-4.12.1.ebuild')
-rw-r--r--kde-base/kalgebra/kalgebra-4.12.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/kalgebra/kalgebra-4.12.1.ebuild b/kde-base/kalgebra/kalgebra-4.12.1.ebuild
new file mode 100644
index 000000000000..60fc79b601c2
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.12.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.12.1.ebuild,v 1.1 2014/01/18 11:24:05 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+HOMEPAGE="http://www.kde.org/applications/education/kalgebra
+http://edu.kde.org/kalgebra"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep analitza opengl?)
+ $(add_kdebase_dep libkdeedu)
+ opengl? ( virtual/glu )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-base_src_configure
+}