summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
commit07a5746d946658a2d5d39b2008bdad2d2b2e127c (patch)
treea949b9dad962aee8c01f5011d077283fc50836d4 /kde-base/kalzium
parent[profiles/arch/powerpc] Update kde mask (diff)
downloadgentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.gz
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.bz2
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.zip
[kde-base] KDE SC 4.7.3
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.7.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 9154f1585cc5..1ba3e3acc30d 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.203 2011/10/28 19:03:41 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.204 2011/11/02 20:48:07 alexxy Exp $
+
+*kalzium-4.7.3 (02 Nov 2011)
+
+ 02 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.7.3.ebuild:
+ Version bump KDE SC 4.7.3
28 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -kalzium-4.7.1.ebuild:
Drop KDEpim 4.6.1 and KDE 4.7.1
diff --git a/kde-base/kalzium/kalzium-4.7.3.ebuild b/kde-base/kalzium/kalzium-4.7.3.ebuild
new file mode 100644
index 000000000000..4e45d5a1a0f2
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.7.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.7.3.ebuild,v 1.1 2011/11/02 20:48:07 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}
+
+src_test(){ :; } #see bug 376911