summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commit588eb8e56926b65029e4de63aa398e51ed8cc9b8 (patch)
tree356a5e95843b62ad54fc9c77facba6ff67c4db94 /kde-base/kalzium
parentx86 stable, bug 323729 (diff)
downloadgentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.gz
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.bz2
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.zip
[kde-base] Bump KDE SC 4.4.5 =)
(Portage version: 2.2_rc67_p182/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.4.5.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index e98fb304ad35..f55766a7ebd1 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.168 2010/06/27 09:48:22 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.169 2010/06/30 15:36:35 alexxy Exp $
+
+*kalzium-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.4.5.ebuild:
+ Version bump
27 Jun 2010; Christian Faulhammer <fauli@gentoo.org> kalzium-4.4.4.ebuild:
x86 stable, bug 322791
diff --git a/kde-base/kalzium/kalzium-4.4.5.ebuild b/kde-base/kalzium/kalzium-4.4.5.ebuild
new file mode 100644
index 000000000000..ec3631289dd2
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.4.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.4.5.ebuild,v 1.1 2010/06/30 15:36:35 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +handbook +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-meta_src_configure
+}