summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-07 04:58:00 +0000
commitd7e1a4366ff9ba481421bd6f31539139be38e99a (patch)
tree06cf6fc3ad2522bd965c90e770efaf564b4caf81 /kde-base/kcheckpass
parentMask KDE SC 4.10.0 for keywording bug #455960 (diff)
downloadgentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.gz
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.tar.bz2
gentoo-2-d7e1a4366ff9ba481421bd6f31539139be38e99a.zip
Add KDE SC 4.10.0
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.10.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index c48abf4f76fd..f90ae18b66a1 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.251 2013/01/28 12:12:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.252 2013/02/07 04:57:36 alexxy Exp $
+
+*kcheckpass-4.10.0 (06 Feb 2013)
+
+ 06 Feb 2013; Alexey Shvetsov <alexxy@gentoo.org> +kcheckpass-4.10.0.ebuild:
+ Version bump KDE SC 4.10.0
28 Jan 2013; Agostino Sarubbo <ago@gentoo.org> -kcheckpass-4.9.3.ebuild,
-kcheckpass-4.9.4.ebuild:
diff --git a/kde-base/kcheckpass/kcheckpass-4.10.0.ebuild b/kde-base/kcheckpass/kcheckpass-4.10.0.ebuild
new file mode 100644
index 000000000000..fbce1282079c
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.10.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.10.0.ebuild,v 1.1 2013/02/07 04:57:36 alexxy Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}
+ x11-libs/libxkbfile
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}