summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 22:43:37 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 22:43:37 +0000
commitf995e1c588d1e113f6fedc33de9d8188f1170fbf (patch)
tree08e7afb8f37487f03f6a2934a7c27c238f4ab58b /kde-base/kdeadmin
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-f995e1c588d1e113f6fedc33de9d8188f1170fbf.tar.gz
gentoo-2-f995e1c588d1e113f6fedc33de9d8188f1170fbf.tar.bz2
gentoo-2-f995e1c588d1e113f6fedc33de9d8188f1170fbf.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kdeadmin')
-rw-r--r--kde-base/kdeadmin/ChangeLog8
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.5.9.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kdeadmin/ChangeLog b/kde-base/kdeadmin/ChangeLog
index cff0d4053246..dc09910dcb8b 100644
--- a/kde-base/kdeadmin/ChangeLog
+++ b/kde-base/kdeadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeadmin
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.209 2008/02/19 00:00:30 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.210 2008/02/20 22:43:37 philantrop Exp $
+
+*kdeadmin-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdeadmin-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
18 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/lilo-config-4.0.0.patch, -kdeadmin-4.0.0.ebuild:
diff --git a/kde-base/kdeadmin/kdeadmin-3.5.9.ebuild b/kde-base/kdeadmin/kdeadmin-3.5.9.ebuild
new file mode 100644
index 000000000000..ea51dc706816
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.5.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.5.9.ebuild,v 1.1 2008/02/20 22:43:37 philantrop Exp $
+
+EAPI="1"
+inherit kde-dist
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kdehiddenvisibility"
+
+DEPEND="~kde-base/kdebase-${PV}"
+RDEPEND="${DEPEND}
+ virtual/cron"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix the desktop file.
+ sed -i -e "s:\(Configuration-KDE-Network-mdk\):X-\1:" \
+ "${S}/knetworkconf/knetworkconf/kcm_knetworkconfmodule.desktop"
+}
+
+src_compile() {
+ # we only want to compile the lilo config module on x86, but there we want to make sure it's
+ # always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+ # because configure when left to its own devices will build lilo-config or not basd on whether
+ # lilo is present in the path.
+ # so, we make configure build it by removing the configure.in.in file that checks for
+ # lilo's presense
+ if use x86; then
+ echo > "${S}/lilo-config/configure.in.in"
+ emake -f admin/Makefile.common
+ fi
+
+ local myconf="--with-shadow"
+
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} ksysv"
+
+ kde_src_compile
+}