summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
commita7d39b161d3ea87618db515020379fc2be385858 (patch)
tree3fd47e295f81d71610e045a95b9b7a70e5373756 /kde-base/kdebase-data/kdebase-data-4.11.1.ebuild
parentAdd systemd support (#466084) (diff)
downloadgentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.gz
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.bz2
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.zip
Bump KDE to 4.1.1
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kdebase-data/kdebase-data-4.11.1.ebuild')
-rw-r--r--kde-base/kdebase-data/kdebase-data-4.11.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdebase-data/kdebase-data-4.11.1.ebuild b/kde-base/kdebase-data/kdebase-data-4.11.1.ebuild
new file mode 100644
index 000000000000..21968310b9a1
--- /dev/null
+++ b/kde-base/kdebase-data/kdebase-data-4.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-data/kdebase-data-4.11.1.ebuild,v 1.1 2013/09/03 19:04:35 creffett Exp $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase."
+IUSE="+wallpapers"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ wallpapers? ( $(add_kdebase_dep kde-wallpapers) )
+ $(add_kdebase_dep oxygen-icons)
+ x11-themes/hicolor-icon-theme
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}