summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-09 19:13:24 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-09 19:13:24 +0000
commit1519cea382a192571d657d073a8f66c69b8d82d9 (patch)
tree46971514ed8992dd858db3077de00dc1791a7083 /kde-base/kdebase
parentupdated to latest version and added init.d-script (diff)
downloadgentoo-2-1519cea382a192571d657d073a8f66c69b8d82d9.tar.gz
gentoo-2-1519cea382a192571d657d073a8f66c69b8d82d9.tar.bz2
gentoo-2-1519cea382a192571d657d073a8f66c69b8d82d9.zip
new multi-kdedirs support. see anouncement on gentoo-* in 5 minutes. enjoy!
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/files/digest-kdebase-2.2.2-r11
-rw-r--r--kde-base/kdebase/files/startkde-2.2.2125
-rw-r--r--kde-base/kdebase/kdebase-2.2.2-r1.ebuild69
3 files changed, 195 insertions, 0 deletions
diff --git a/kde-base/kdebase/files/digest-kdebase-2.2.2-r1 b/kde-base/kdebase/files/digest-kdebase-2.2.2-r1
new file mode 100644
index 000000000000..a66cb7601fc2
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-2.2.2-r1
@@ -0,0 +1 @@
+MD5 39635e42056ab2afb8e6f2ff761eea38 kdebase-2.2.2.tar.bz2 12890112
diff --git a/kde-base/kdebase/files/startkde-2.2.2 b/kde-base/kdebase/files/startkde-2.2.2
new file mode 100644
index 000000000000..a16950775c2c
--- /dev/null
+++ b/kde-base/kdebase/files/startkde-2.2.2
@@ -0,0 +1,125 @@
+#!/bin/bash --login
+export KDEDIR="_KDEDIR_"
+export PATH="_KDEDIR_/bin:${PATH}"
+rm -rf ~/.kde
+ln -fs ~/.kde2 ~/.kde
+[ -e "~/.kde2" ] || mkdir ~/.kde2
+####################################################
+# DEFAULT GENTOO KDE STARTUP SCRIPT ( KDE-2.2.2 ) ##
+####################################################
+
+#################################
+#Initial cleanup of old sessions#
+#################################
+real_display=`echo $DISPLAY | sed "s/://" | sed "s/\..*//"`
+rm -f ~/.DCOPserver-`/bin/hostname`_$DISPLAY
+
+#####################################
+#Check for space on /tmp and "$HOME"#
+#If not, abort startup #
+#####################################
+space_tmp=`df /tmp | xargs | cut -d" " -f11`
+space_home=`df "$HOME" | xargs | cut -d" " -f11`
+
+if [ $space_tmp -lt 50 ]; then
+ echo $"Not enough free disk space on /tmp"
+ exit 1
+fi
+
+if [ $space_home -lt 25 ]; then
+ echo $"Not enough free disk space on "$HOME""
+ exit 1
+fi
+
+############################################
+#Check for write access on /tmp and "$HOME"#
+#If not, abort startup #
+############################################
+testfile_tmp=`mktemp /tmp/KDE.startkde.XXXXXX`
+testfile_home=`mktemp "$HOME"/KDE.startkde.XXXXXX`
+
+if ! echo TEST_TEXT >$testfile_tmp 2>/dev/null ; then
+ echo $"You don't have write permissions for /tmp"
+ exit 1
+fi
+rm -f $testfile_tmp
+
+if ! echo TEST_TEXT >$testfile_home 2>/dev/null ; then
+ echo $"You don't have write permissions for "$HOME""
+ exit 1
+fi
+rm -f $testfile_home
+
+##########################
+#Set Background and stuff#
+##########################
+xsetroot -cursor_name left_ptr -solid '#5477A0'
+
+#####################
+#Set the KDE Home...#
+####################
+kdehome=$HOME/.kde
+test -n "$KDEHOME" && kdehome=$KDEHOME
+
+###########################
+#Activate Font Directories#
+###########################
+usr_odir=$kdehome/share/fonts/override
+usr_fdir=$kdehome/share/fonts
+if test -n "$KDEDIRS"; then
+ kdedirs_first=`echo $KDEDIRS|sed -e 's/:.*//'`
+ sys_odir=$kdedirs_first/share/fonts/override
+ sys_fdir=$kdedirs_first/share/fonts
+else
+ sys_odir=$KDEDIR/share/fonts/override
+ sys_fdir=$KDEDIR/share/fonts
+fi
+
+########################################################
+#Check for newly installed fonts, if we have permission#
+########################################################
+
+test -d $usr_odir && (mkfontdir $usr_odir ; xset +fp $usr_odir)
+test -d $sys_odir && xset +fp $sys_odir
+test -d $usr_fdir && (mkfontdir $usr_fdir ; xset fp+ $usr_fdir)
+test -d $sys_fdir && xset fp+ $sys_fdir
+
+####################################
+# Ask X11 to rebuild its font list.#
+####################################
+xset fp rehash
+
+##################################################################
+#Link "tmp" resource to directory in /tmp #
+#Create a dir /tmp/kde-$USER, links $KDEHOME/tmp-$HOSTNAME to it.#
+##################################################################
+lnusertemp tmp >/dev/null
+
+########################################################################
+#Link "socket" resource to directory in /tmp #
+#Create a dir /tmp/ksocket-$USER, links $KDEHOME/socket-$HOSTNAME to it#
+########################################################################
+lnusertemp socket >/dev/null
+
+########################
+#Start the splashscreen#
+########################
+ksplash
+
+###########################################################
+#Set LD_BIND_NOW to increase the efficiency of kdeinit. #
+#kdeinit unsets this variable before loading applications.#
+###########################################################
+# turn it off, it creates aa trouble
+#LD_BIND_NOW=true kdeinit +kcminit +knotify
+kdeinit +kcminit +knotify
+
+###########################################################
+# finally, give the session control to the session manager#
+###########################################################
+ksmserver --restore
+
+##########
+#Clean up#
+##########
+kdeinit_shutdown
diff --git a/kde-base/kdebase/kdebase-2.2.2-r1.ebuild b/kde-base/kdebase/kdebase-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..187abcc6a6b4
--- /dev/null
+++ b/kde-base/kdebase/kdebase-2.2.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-2.2.2-r1.ebuild,v 1.1 2002/01/09 19:13:23 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Base"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ lame? ( >=media-sound/lame-3.89b )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ media-sound/cdparanoia
+ opengl? ( virtual/opengl )" #this last for opengl screensavers
+# samba? ( net-fs/samba ) #use flag doesn't exist yet and we don't want such a heavy dep by deafult
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+ use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+ use motif || myconf="$myconf --without-motif"
+ use lame || myconf="$myconf --without-lame"
+ use cups || myconf="$myconf --disable-cups"
+ use vorbis || myconf="$myconf --without-vorbis"
+ use opengl || myconf="$myconf --without-gl"
+ use ssl || myconf="$myconf --without-ssl"
+
+ kde_src_compile configure make
+
+}
+
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ cd ${D}/${KDEDIR}/bin
+ rm -f ./startkde
+ sed -e "s:_KDEDIR_:${KDEDIR}:" ${FILESDIR}/startkde-${PV} > startkde
+ chmod a+x startkde
+
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/xsession
+
+ cd ${D}/usr/X11R6/bin/wm
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm
+ mv kdmrc kdmrc.orig
+ sed -e 's/SessionTypes=/SessionTypes=kde-2.2.2,kde-3.0,xsession,/' kdmrc.orig | cat > kdmrc
+ rm kdmrc.orig
+
+ dodir ${KDEDIR}/share/templates/.source/emptydir
+
+}