summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-04-23 00:23:40 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-04-23 00:23:40 +0000
commit6df35fe99c2c2fd9474f9c54253901a8fd69c07b (patch)
tree5e9dcc7804046de694971fd55cb543fb95076942 /kde-base/kdebindings
parentinit file cleaned up. Ebuild cleaned up. Removed old packages. (Manifest re... (diff)
downloadgentoo-2-6df35fe99c2c2fd9474f9c54253901a8fd69c07b.tar.gz
gentoo-2-6df35fe99c2c2fd9474f9c54253901a8fd69c07b.tar.bz2
gentoo-2-6df35fe99c2c2fd9474f9c54253901a8fd69c07b.zip
Move java-config inside ebuild so it's not in global scope
Diffstat (limited to 'kde-base/kdebindings')
-rw-r--r--kde-base/kdebindings/kdebindings-3.1.5.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/kde-base/kdebindings/kdebindings-3.1.5.ebuild b/kde-base/kdebindings/kdebindings-3.1.5.ebuild
index 50fb49d8d529..b458a6d64870 100644
--- a/kde-base/kdebindings/kdebindings-3.1.5.ebuild
+++ b/kde-base/kdebindings/kdebindings-3.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1.5.ebuild,v 1.3 2004/03/25 22:56:22 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1.5.ebuild,v 1.4 2004/04/23 00:23:40 caleb Exp $
# TODO: add gnustep, objc bindings
inherit kde-dist
@@ -17,8 +17,7 @@ DEPEND="=kde-base/kdebase-${PV}*
~kde-base/kdenetwork-${PV}
mozilla? ( net-www/mozilla )"
-use python || myconf="$myconf --without-python"
-use java && myconf="$myconf --with-java=`java-config --jdk-home`" || myconf="$myconf --without-java"
+use python || myconf="$myconf --without-python"
# obj bindings are officially broken
#myconf="$myconf --enable-objc"
@@ -46,3 +45,8 @@ src_unpack()
cd ${S} && aclocal
}
+src_compile()
+{
+ use java && myconf="$myconf --with-java=`java-config --jdk-home`" || myconf="$myconf --without-java"
+ kde_src_compile
+}