summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-30 20:49:29 +0000
committerDror Levin <spatz@gentoo.org>2010-03-30 20:49:29 +0000
commitddae61a086991ea2a6e2eb394409a6d8818227fb (patch)
tree311b4632d856b207357898c77e312e4a327a08dd /kde-base/kdepim-runtime/kdepim-runtime-4.4.2.ebuild
parentVersion bump KDE 4.4.2 (diff)
downloadgentoo-2-ddae61a086991ea2a6e2eb394409a6d8818227fb.tar.gz
gentoo-2-ddae61a086991ea2a6e2eb394409a6d8818227fb.tar.bz2
gentoo-2-ddae61a086991ea2a6e2eb394409a6d8818227fb.zip
Version bump KDE 4.4.2
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdepim-runtime/kdepim-runtime-4.4.2.ebuild')
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.4.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.4.2.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.4.2.ebuild
new file mode 100644
index 000000000000..aa2296ec22c8
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.4.2.ebuild,v 1.1 2010/03/30 20:49:29 spatz Exp $
+
+EAPI="3"
+
+if [[ ${PV} = *9999* ]]; then
+ KMNAME="kdepim"
+ KMMODULE="runtime"
+ inherit kde4-meta
+else
+ inherit kde4-base
+fi
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.2.1
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'akonadi')
+ $(add_kdebase_dep libkdepim)
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+"
+
+add_blocker akonadi '<4.3.90'