summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:16:18 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:16:18 +0000
commit0dc81e7a9ef8e256e3b350344c512b9bf2e5fa61 (patch)
treead171aee26d4fc9fb3b28ac01fbeaa6fc8515652 /kde-base/kdepimlibs
parent[kde-base/lilo-config] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-0dc81e7a9ef8e256e3b350344c512b9bf2e5fa61.tar.gz
gentoo-2-0dc81e7a9ef8e256e3b350344c512b9bf2e5fa61.tar.bz2
gentoo-2-0dc81e7a9ef8e256e3b350344c512b9bf2e5fa61.zip
[kde-base/kdepimlibs] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.4.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 5820159778c6..eb071fe64b3d 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.61 2010/01/25 15:27:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.62 2010/02/09 00:16:18 alexxy Exp $
+
+*kdepimlibs-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +kdepimlibs-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*kdepimlibs-4.3.5 (25 Jan 2010)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.4.0.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.4.0.ebuild
new file mode 100644
index 000000000000..558d153c3248
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.4.0.ebuild,v 1.1 2010/02/09 00:16:18 alexxy Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="+akonadi debug +handbook ldap"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=dev-libs/boost-1.35.0-r5
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ akonadi? ( >=app-office/akonadi-server-1.3.0 )
+ ldap? ( net-nds/openldap )
+"
+RDEPEND="${DEPEND}"
+
+# libakonadi-kcal moved here from akonadi in 4.3.86
+add_blocker akonadi '<4.3.86'
+# @since 4.3 - libkholidays is in kdepimlibs now
+add_blocker libkholidays
+# @since 4.4 - kontactinterfaces is in kdepimlibs now
+add_blocker kontactinterfaces
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use akonadi; then
+ sed -e '/find_package(Akonadi/s/^/# DISABLED /' \
+ -e '/macro_log_feature(Akonadi_FOUND/s/TRUE/FALSE/' \
+ -e '/add_subdirectory(akonadi)/s/^/# DISABLED /' \
+ -e '/add_subdirectory(mailtransport)/s/^/# DISABLED /' \
+ -i CMakeLists.txt || die "failed to disable akonadi"
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)
+ )
+
+ kde4-base_src_configure
+}