summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
committerJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
commitf8633b9ab4fbc263024fc7d9e4b25610366de9c2 (patch)
tree6a1fa56dffbbac34e8c5f2f3a57fbdac07646b6c /kde-base/kdepimlibs
parentAlways download/symlink unifont, bug 522956. (diff)
downloadgentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.gz
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.bz2
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.zip
Version bump KDE SC 4.14.1
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.14.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 7504d490e443..c87cf280e9b6 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.280 2014/08/20 16:02:45 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.281 2014/09/16 18:17:34 johu Exp $
+
+*kdepimlibs-4.14.1 (16 Sep 2014)
+
+ 16 Sep 2014; Johannes Huber <johu@gentoo.org> +kdepimlibs-4.14.1.ebuild:
+ Version bump KDE SC 4.14.1
*kdepimlibs-4.14.0 (20 Aug 2014)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.14.1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.14.1.ebuild
new file mode 100644
index 000000000000..d9c8507a2b47
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.14.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.14.1.ebuild,v 1.1 2014/09/16 18:17:34 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap prison"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ !kde-misc/akonadi-social-utils
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.12.90[qt4]
+ >=dev-libs/boost-1.35.0-r5:=
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.48-r2:=
+ dev-libs/cyrus-sasl
+ >=dev-libs/qjson-0.8.1
+ media-libs/phonon[qt4]
+ x11-misc/shared-mime-info
+ prison? ( media-libs/prison:4 )
+ ldap? ( net-nds/openldap )
+"
+# boost is not linked to, but headers which include it are installed
+# bug #418071
+RDEPEND="${DEPEND}
+ !=kde-base/kdepim-runtime-4.10*
+ !=kde-base/kdepim-runtime-4.11*
+ !<kde-base/kdepim-runtime-4.4.11.1-r2
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.9.1-boostincludes.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_find_package ldap)
+ $(cmake-utils_use_find_package prison)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ rm "${ED}"/usr/share/apps/cmake/modules/FindQtOAuth.cmake #Collides with net-im/choqok
+}