summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
commit14c988d01f8c84ab2bd2faa3c01c646602dc1692 (patch)
tree4b095bcf239f3426af85e14e94933b79e8588042 /kde-base/kdesu/kdesu-4.12.1.ebuild
parentCleanup. (diff)
downloadgentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.gz
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.bz2
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.zip
Version bump KDE SC 4.12.1
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kdesu/kdesu-4.12.1.ebuild')
-rw-r--r--kde-base/kdesu/kdesu-4.12.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kdesu/kdesu-4.12.1.ebuild b/kde-base/kdesu/kdesu-4.12.1.ebuild
new file mode 100644
index 000000000000..9dba014e0bf9
--- /dev/null
+++ b/kde-base/kdesu/kdesu-4.12.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/kdesu-4.12.1.ebuild,v 1.1 2014/01/18 11:23:44 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-runtime"
+inherit kde4-meta
+
+# FIXME: Is default command ( su/sudo ) still configurable,
+# if not, USE-flag ?
+DESCRIPTION="KDE: gui for su(1)"
+HOMEPAGE+=" http://techbase.kde.org/Projects/kdesu"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+src_configure() {
+ # Upstream moved kdesu to libexec first, then decided to move it back
+ # to /${PREFIX}/bin/ , so I'm doing that now already.
+ sed -e '/kdesu_executable/s:LIBEXEC_INSTALL_DIR:BIN_INSTALL_DIR:' \
+ -i "${S}"/kdesu/kdesu/CMakeLists.txt || \
+ die "Moving kdesu from libexec to bin failed."
+
+ kde4-meta_src_configure
+}