summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-27 01:30:55 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-27 01:30:55 +0000
commit697fecf0fa73943f89b63eaad39fcad8cc2834de (patch)
treefaffe9085524a47e34d1b142ff4323f22a6927f9 /kde-base/kdeutils
parentAdded a patch to fix ejecting by using HAL (if the necessary tools are instal... (diff)
downloadgentoo-2-697fecf0fa73943f89b63eaad39fcad8cc2834de.tar.gz
gentoo-2-697fecf0fa73943f89b63eaad39fcad8cc2834de.tar.bz2
gentoo-2-697fecf0fa73943f89b63eaad39fcad8cc2834de.zip
Added a patch by Thomas Anderson to fix the paths to several KDE applications as kindly provided on bug 195525.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'kde-base/kdeutils')
-rw-r--r--kde-base/kdeutils/ChangeLog9
-rw-r--r--kde-base/kdeutils/files/kmilo-3.5.9-fixpaths.patch20
-rw-r--r--kde-base/kdeutils/kdeutils-3.5.9-r1.ebuild69
3 files changed, 97 insertions, 1 deletions
diff --git a/kde-base/kdeutils/ChangeLog b/kde-base/kdeutils/ChangeLog
index 363f443b7bbc..a99da103971e 100644
--- a/kde-base/kdeutils/ChangeLog
+++ b/kde-base/kdeutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdeutils
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.228 2008/03/07 00:40:10 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.229 2008/04/27 01:30:55 philantrop Exp $
+
+*kdeutils-3.5.9-r1 (27 Apr 2008)
+
+ 27 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kmilo-3.5.9-fixpaths.patch, +kdeutils-3.5.9-r1.ebuild:
+ Added a patch by Thomas Anderson to fix the paths to several KDE
+ applications as kindly provided on bug 195525.
07 Mar 2008; Ryan Hill <dirtyepic@gentoo.org> kdeutils-3.5.9.ebuild:
Keyword ~mips.
diff --git a/kde-base/kdeutils/files/kmilo-3.5.9-fixpaths.patch b/kde-base/kdeutils/files/kmilo-3.5.9-fixpaths.patch
new file mode 100644
index 000000000000..6d8a98182260
--- /dev/null
+++ b/kde-base/kdeutils/files/kmilo-3.5.9-fixpaths.patch
@@ -0,0 +1,20 @@
+diff -Naur kdeutils-3.5.7-orig/kmilo/thinkpad/thinkpad.cpp kdeutils-3.5.7/kmilo/thinkpad/thinkpad.cpp
+--- kdeutils-3.5.7-orig/kmilo/thinkpad/thinkpad.cpp 2008-01-23 20:36:29.000000000 -0500
++++ kdeutils-3.5.7/kmilo/thinkpad/thinkpad.cpp 2008-01-23 20:38:09.000000000 -0500
+@@ -443,11 +443,11 @@
+ m_softwareVolume = config->readBoolEntry("softwareVolume", true);
+ m_run = config->readBoolEntry("run", false);
+ m_volumeStep = config->readNumEntry("volumeStep", defaultVolumeStep);
+- m_buttonThinkpad = config->readEntry("buttonThinkpad", "/usr/bin/konsole");
+- m_buttonHome = config->readEntry("buttonHome", "/usr/bin/konqueror");
+- m_buttonSearch = config->readEntry("buttonSearch", "/usr/bin/kfind");
+- m_buttonMail = config->readEntry("buttonMail", "/usr/bin/kmail");
+- m_buttonZoom = config->readEntry("buttonZoom", "/usr/bin/ksnapshot");
++ m_buttonThinkpad = config->readEntry("buttonThinkpad", "/usr/kde/3.5/bin/konsole");
++ m_buttonHome = config->readEntry("buttonHome", "/usr/kde/3.5/bin/konqueror");
++ m_buttonSearch = config->readEntry("buttonSearch", "/usr/kde/3.5/bin/kfind");
++ m_buttonMail = config->readEntry("buttonMail", "/usr/kde/3.5/bin/kmail");
++ m_buttonZoom = config->readEntry("buttonZoom", "/usr/kde/3.5/bin/ksnapshot");
+ }
+
+ bool ThinkPadMonitor::retrieveVolume() {
diff --git a/kde-base/kdeutils/kdeutils-3.5.9-r1.ebuild b/kde-base/kdeutils/kdeutils-3.5.9-r1.ebuild
new file mode 100644
index 000000000000..526d13906acb
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.5.9-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.5.9-r1.ebuild,v 1.1 2008/04/27 01:30:55 philantrop Exp $
+
+EAPI="1"
+inherit kde-dist eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdeutils-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE utilities."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt kdehiddenvisibility pbbuttonsd snmp xscreensaver"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ snmp? ( net-analyzer/net-snmp )
+ pbbuttonsd? ( app-laptop/pbbuttonsd )
+ dev-lang/python
+ dev-libs/gmp
+ x11-libs/libXtst"
+
+RDEPEND="${BOTH_DEPEND}
+ crypt? ( app-crypt/gnupg
+ app-crypt/pinentry )"
+
+DEPEND="${BOTH_DEPEND}
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/os-headers"
+
+PATCHES=( "${FILESDIR}/superkaramba-3.5.7-network_sensor.patch"
+ "${FILESDIR}/kmilo-${PV}-fixpaths.patch" )
+EPATCH_EXCLUDE="klaptopdaemon-3.5-suspend2+xsession-errors.diff
+ klaptopdaemon-3.5-lock-and-hibernate.diff"
+
+pkg_setup() {
+ if use crypt && ! built_with_use app-crypt/pinentry gtk && ! built_with_use app-crypt/pinentry qt3 ; then
+ eerror "kgpg needs app-crypt/pinentry built with either the gtk or qt3 USE flag."
+ eerror "Please enable either USE flag and re-install app-crypt/pinentry."
+ die "app-crypt/pinentry needs to be rebuilt with gtk or qt3 support."
+ fi
+
+ kde_pkg_setup
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix some desktop files
+ sed -i -e "s:Hidden=true:Hidden=false:" "${S}/ksim/ksim.desktop" \
+ || die "sed (ksim) failed"
+ sed -i -e "s:\(^Type=\)Service:\1Application:" "${S}/kdelirc/irkick/irkick.desktop" \
+ || die "sed (irkick) failed"
+ sed -i -e "s:\(^Init=.*\):X-\1:" "${S}/klaptopdaemon/applnk/laptop.desktop" \
+ || die "sed (laptop) failed"
+}
+
+src_compile() {
+ local myconf="$(use_with snmp)
+ $(use_with pbbuttonsd powerbook)
+ $(use_with xscreensaver)
+ --without-xmms"
+
+ use crypt || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kgpg"
+
+ kde_src_compile
+}