summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-04-23 17:12:50 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-04-23 17:12:50 +0000
commit1832c8fe0a118e2de60957917196320770957132 (patch)
tree18a4d291dd18e688b651a71aaee8c2d6f251f4f0 /kde-base/kmail
parentInitial version. (diff)
downloadgentoo-2-1832c8fe0a118e2de60957917196320770957132.tar.gz
gentoo-2-1832c8fe0a118e2de60957917196320770957132.tar.bz2
gentoo-2-1832c8fe0a118e2de60957917196320770957132.zip
Version bump KDEPIM 4.5.95 (4.6 beta 5)
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/kmail-4.5.95.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index d7d0665ed3aa..8c0693c2f92a 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.245 2011/04/22 12:12:50 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.246 2011/04/23 17:12:49 tampakrap Exp $
+
+*kmail-4.5.95 (23 Apr 2011)
+
+ 23 Apr 2011; Theo Chatzimichos <tampakrap@gentoo.org> +kmail-4.5.95.ebuild:
+ Version bump KDEPIM 4.5.95 (4.6 beta 5)
22 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
kmail-4.4.11.1.ebuild:
diff --git a/kde-base/kmail/kmail-4.5.95.ebuild b/kde-base/kmail/kmail-4.5.95.ebuild
new file mode 100644
index 000000000000..96f80baf4e0d
--- /dev/null
+++ b/kde-base/kmail/kmail-4.5.95.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.5.95.ebuild,v 1.1 2011/04/23 17:12:49 tampakrap Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+add_blocker kmailcvt
+add_blocker libksieve
+add_blocker mimelib
+
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarsupport/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ mailcommon/
+ ontologies/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}