summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
commitb19b0ead03dc10cdaa9aea4001d560c962a1f597 (patch)
treef22852d83a670996da46e118f610a0f6dfa2f4ba /kde-base/kmail
parentsys-kernel/aufs-sources: Fix problem due to renamed tmpfs patch, #513332 (diff)
downloadgentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.gz
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.bz2
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.zip
Version bump KDE SC 4.13.2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/kmail-4.13.2.ebuild112
2 files changed, 118 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 81d81ba2181a..213c264cec0b 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.415 2014/05/13 22:53:23 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.416 2014/06/15 16:56:55 kensington Exp $
+
+*kmail-4.13.2 (15 Jun 2014)
+
+ 15 Jun 2014; Michael Palimaka <kensington@gentoo.org> +kmail-4.13.2.ebuild:
+ Version bump KDE SC 4.13.2
*kmail-4.4.11.1-r2 (13 May 2014)
diff --git a/kde-base/kmail/kmail-4.13.2.ebuild b/kde-base/kmail/kmail-4.13.2.ebuild
new file mode 100644
index 000000000000..4b158687ffa5
--- /dev/null
+++ b/kde-base/kmail/kmail-4.13.2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.13.2.ebuild,v 1.1 2014/06/15 16:56:55 kensington Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+VIRTUALX_REQUIRED=test
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+HOMEPAGE="http://www.kde.org/applications/internet/kmail/"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs "" 4.12.1-r2)
+"
+RDEPEND="
+ ${DEPEND}
+ !=kde-base/kdepim-common-libs-4.12.1-r1
+"
+
+RESTRICT="test"
+# bug 393147
+
+KMEXTRACTONLY="
+ agents/folderarchiveagent.desktop
+ agents/sendlateragent/
+ akonadi_next/
+ calendarsupport/
+ calendarviews/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ grantleetheme/
+ kaddressbookgrantlee/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ pimcommon/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+ noteshared/
+"
+KMEXTRA="
+ agents/archivemailagent/
+ agents/mailfilteragent/
+ grantleethemeeditor/
+ headerthemeeditor/
+ kmailcvt/
+ ksendemail/
+ importwizard/
+ libksieve/
+ mailcommon/
+ mailimporter/
+ mboximporter/
+ pimsettingexporter/
+ plugins/messageviewer/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+
+ if has_version "app-office/akonadi-server[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you set your Akonadi database backend to QMYSQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "Reports indicate that kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ if has_version "app-office/akonadi-server[-mysql]"; then
+ ewarn "FOR THAT, YOU WILL HAVE TO RE-BUILD app-office/akonadi-server WITH mysql USEFLAG ENABLED."
+ fi
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn
+ fi
+}