summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-01-29 12:39:47 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-01-29 12:39:47 +0000
commit008209b8327702eddf8d4b07d1e7ca42a9a4edc9 (patch)
treea0f73bae5cfbb94bf9ec26da33034fda11a87798 /kde-base/konq-plugins
parentAs Ari Entlich was right to remark on #linux-wireless, 0.6.4 != 0.5.8 (diff)
downloadgentoo-2-008209b8327702eddf8d4b07d1e7ca42a9a4edc9.tar.gz
gentoo-2-008209b8327702eddf8d4b07d1e7ca42a9a4edc9.tar.bz2
gentoo-2-008209b8327702eddf8d4b07d1e7ca42a9a4edc9.zip
Version bump. Per bug #256719.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/konq-plugins')
-rw-r--r--kde-base/konq-plugins/ChangeLog8
-rw-r--r--kde-base/konq-plugins/konq-plugins-4.2.0.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/konq-plugins/ChangeLog b/kde-base/konq-plugins/ChangeLog
index 1216120ab9e3..08e0d581bd20 100644
--- a/kde-base/konq-plugins/ChangeLog
+++ b/kde-base/konq-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/konq-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/ChangeLog,v 1.97 2009/01/14 15:19:51 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/ChangeLog,v 1.98 2009/01/29 12:39:47 scarabeus Exp $
+
+*konq-plugins-4.2.0 (29 Jan 2009)
+
+ 29 Jan 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +konq-plugins-4.2.0.ebuild:
+ Version bump. Per bug #256719
14 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org>
-konq-plugins-4.1.3.ebuild:
diff --git a/kde-base/konq-plugins/konq-plugins-4.2.0.ebuild b/kde-base/konq-plugins/konq-plugins-4.2.0.ebuild
new file mode 100644
index 000000000000..3fa632ecc4e9
--- /dev/null
+++ b/kde-base/konq-plugins/konq-plugins-4.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/konq-plugins-4.2.0.ebuild,v 1.1 2009/01/29 12:39:47 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="extragear/base"
+KMNOMODULE="true"
+inherit kde4-base
+
+DESCRIPTION="Various plugins for konqueror"
+HOMEPAGE="htts://kde.org/"
+SRC_URI="mirror://kde/stable/4.2.0/src/extragear/${P}.tar.bz2"
+SLOT="4.2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook"
+
+RDEPEND="!kde-misc/konq-plugins
+ !kdeprefix? ( !kde-base/konq-plugins:4.1[-kdeprefix] )
+ >=kde-base/konqueror-${KDE_MINIMAL}
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if ! use htmlhandbook; then
+ sed -i \
+ -e "s:macro_optional_add_subdirectory(doc):#nada:g" \
+ CMakeLists.txt || die "sed doc failed"
+ fi
+}