summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-11-19 19:51:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-11-19 19:51:11 +0000
commit4b829b67879a53942c78238dcf4e8024c32755bc (patch)
treea1807db845131e6092ed89cccab74ebd9065387f /kde-base/kopete/files
parentRemove KDE 3.5.10. (diff)
downloadgentoo-2-4b829b67879a53942c78238dcf4e8024c32755bc.tar.gz
gentoo-2-4b829b67879a53942c78238dcf4e8024c32755bc.tar.bz2
gentoo-2-4b829b67879a53942c78238dcf4e8024c32755bc.zip
Remove KDE 3.5.10.
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kopete/files')
-rw-r--r--kde-base/kopete/files/emoticon-manager.patch184
-rw-r--r--kde-base/kopete/files/kdenetwork-3.5.5-linux-headers-2.6.18.patch24
-rw-r--r--kde-base/kopete/files/kopete-0.12_alpha1-xscreensaver.patch25
-rw-r--r--kde-base/kopete/files/kopete-3.5-rolling_icon.patch14
-rw-r--r--kde-base/kopete/files/kopete-3.5.10-gcc43.patch108
-rw-r--r--kde-base/kopete/files/kopete-3.5.10-glibc210.patch22
-rw-r--r--kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch24
-rw-r--r--kde-base/kopete/files/kopete-3.5.10-jabber-protocol-gtalknickfix.patch13
-rw-r--r--kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch19
-rw-r--r--kde-base/kopete/files/kopete-3.5.5-icqfix.patch12
10 files changed, 0 insertions, 445 deletions
diff --git a/kde-base/kopete/files/emoticon-manager.patch b/kde-base/kopete/files/emoticon-manager.patch
deleted file mode 100644
index 890a2e4a18ba..000000000000
--- a/kde-base/kopete/files/emoticon-manager.patch
+++ /dev/null
@@ -1,184 +0,0 @@
-diff -ur kopete-0.12.1.orig/kopete/kopete/chatwindow/chatmessagepart.cpp kopete-0.12.1/kopete/kopete/chatwindow/chatmessagepart.cpp
---- kopete-0.12.1.orig/kopete/kopete/chatwindow/chatmessagepart.cpp 2006-07-13 02:55:47.000000000 +0200
-+++ kopete-0.12.1/kopete/kopete/chatwindow/chatmessagepart.cpp 2006-07-15 21:18:28.000000000 +0200
-@@ -43,6 +43,7 @@
- #include <dom/html_base.h>
- #include <dom/html_document.h>
- #include <dom/html_inline.h>
-+#include <qurloperator.h>
-
-
- // KDE includes
-@@ -60,8 +61,10 @@
- #include <ktempfile.h>
- #include <kurldrag.h>
- #include <kio/netaccess.h>
-+#include <kio/job.h>
- #include <kstandarddirs.h>
- #include <kiconloader.h>
-+#include <kinputdialog.h>
-
- // Kopete includes
- #include "chatmemberslistwidget.h"
-@@ -118,7 +121,7 @@
- Private()
- : tt(0L), manager(0L), scrollPressed(false),
- copyAction(0L), saveAction(0L), printAction(0L),
-- closeAction(0L),copyURLAction(0L), currentChatStyle(0L), latestContact(0L),
-+ closeAction(0L),copyURLAction(0L), currentChatStyle(0L), latestContact(0L), importEmoticon(0L),
- latestDirection(Kopete::Message::Inbound), latestType(Kopete::Message::TypeNormal)
- {}
-
-@@ -144,6 +147,7 @@
- KAction *printAction;
- KAction *closeAction;
- KAction *copyURLAction;
-+ KAction *importEmoticon;
-
- ChatWindowStyle *currentChatStyle;
- Kopete::Contact *latestContact;
-@@ -259,6 +263,7 @@
- d->saveAction = KStdAction::saveAs( this, SLOT(save()), actionCollection() );
- d->printAction = KStdAction::print( this, SLOT(print()),actionCollection() );
- d->closeAction = KStdAction::close( this, SLOT(slotCloseView()),actionCollection() );
-+ d->importEmoticon = new KAction( i18n( "Import Emoticon"), QString::fromLatin1( "importemot" ), 0, this, SLOT( slotImportEmoticon() ), actionCollection() );
- d->copyURLAction = new KAction( i18n( "Copy Link Address" ), QString::fromLatin1( "editcopy" ), 0, this, SLOT( slotCopyURL() ), actionCollection() );
-
- // read formatting override flags
-@@ -281,6 +286,47 @@
- d->scrollPressed = true;
- }
-
-+void ChatMessagePart::slotImportEmoticon()
-+{
-+ kdDebug() << "ChatMessagePart::slotImportEmoticon()" << d->activeElement.getAttribute("src") << endl;
-+ QString emoticonString = KInputDialog::getText( i18n("Import Emoticon"), i18n("<qt><img src=\"%1\"><br>Insert here a shortcut that will be replaced by this emoticon (for instance :P ).</qt>").arg( d->activeElement.getAttribute("src").string() ) );
-+ if (emoticonString.isNull() ) return;
-+ QString xmldirname = KGlobal::dirs()->saveLocation( "emoticons", QString::fromLatin1( "~custom" ), true );
-+ // check if xmlname exists, if not create it
-+ if(xmldirname.isNull() )
-+ {
-+ KMessageBox::error( view(), i18n("There was an error creating the directory for imported emoticons.") );
-+ return;
-+ }
-+ QString xmlname= xmldirname + QString::fromLatin1("/emoticons.xml");
-+ QFile xmlfile(xmlname);
-+ QString text;
-+ QRegExp emoticonMap("(<[\\s]*/[\\s]*messaging-emoticon-map[\\s]*>)");
-+
-+ if( xmlfile.exists() && xmlfile.open(IO_ReadOnly) )
-+ {
-+ text=static_cast<QCString>(xmlfile.readAll());
-+ if(text.contains(emoticonMap)<=0) text=QString::null;
-+ xmlfile.close();
-+ }
-+ if(text.isNull() )
-+ {
-+ text= "<?xml version=\"1.0\"?>\n";
-+ text+= "<messaging-emoticon-map >\n";
-+ text+= "</messaging-emoticon-map>\n";
-+ }
-+ KIO::copy( d->activeElement.getAttribute("src").string(), xmldirname);
-+ QString toAppend="<emoticon file=\"" + QFileInfo(d->activeElement.getAttribute("src").string() ).baseName() + "\">\n";
-+ toAppend+=" <string>" + emoticonString + "</string>\n</emoticon>\n\\1";
-+ xmlfile.open( IO_WriteOnly | IO_Truncate );
-+ QTextStream stream( &xmlfile );
-+ emoticonMap.setCaseSensitive(false);
-+ text=text.replace(emoticonMap, toAppend);
-+ stream << text;
-+ xmlfile.close();
-+ QTimer::singleShot(1500, Kopete::Emoticons::self(), SLOT(reload() ) );
-+}
-+
- void ChatMessagePart::save()
- {
- KFileDialog dlg( QString::null, QString::fromLatin1( "text/html text/plain" ), view(), "fileSaveDialog", false );
-@@ -666,11 +712,12 @@
- d->copyURLAction->plug( chatWindowPopup );
- chatWindowPopup->insertSeparator();
- }
--
-+ kdDebug() << "ChatMessagePart::slotRightClick(): " << d->activeElement.tagName().lower() << endl;
- d->copyAction->setEnabled( hasSelection() );
- d->copyAction->plug( chatWindowPopup );
- d->saveAction->plug( chatWindowPopup );
- d->printAction->plug( chatWindowPopup );
-+ if( d->activeElement.tagName().lower() == "img" ) d->importEmoticon->plug( chatWindowPopup );
- chatWindowPopup->insertSeparator();
- d->closeAction->plug( chatWindowPopup );
-
-Only in kopete-0.12.1/kopete/kopete/chatwindow: chatmessagepart.cpp.orig
-Only in kopete-0.12.1/kopete/kopete/chatwindow: chatmessagepart.cpp.rej
-diff -ur kopete-0.12.1.orig/kopete/kopete/chatwindow/chatmessagepart.h kopete-0.12.1/kopete/kopete/chatwindow/chatmessagepart.h
---- kopete-0.12.1.orig/kopete/kopete/chatwindow/chatmessagepart.h 2006-07-13 02:55:47.000000000 +0200
-+++ kopete-0.12.1/kopete/kopete/chatwindow/chatmessagepart.h 2006-07-15 21:17:45.000000000 +0200
-@@ -148,6 +148,7 @@
- void slotCopyURL();
-
- void slotCloseView( bool force = false );
-+ void slotImportEmoticon();
-
- /**
- * Do the actual style change.
-diff -ur kopete-0.12.1.orig/kopete/kopete/config/appearance/appearanceconfig.cpp kopete-0.12.1/kopete/kopete/config/appearance/appearanceconfig.cpp
---- kopete-0.12.1.orig/kopete/kopete/config/appearance/appearanceconfig.cpp 2006-07-13 02:55:45.000000000 +0200
-+++ kopete-0.12.1/kopete/kopete/config/appearance/appearanceconfig.cpp 2006-07-15 21:17:45.000000000 +0200
-@@ -515,7 +515,7 @@
- {
- QStringList themes = themeQDir.entryList(QDir::Dirs, QDir::Name);
- // We don't care for '.' and '..'
-- if ( themeQDir[y] != "." && themeQDir[y] != ".." )
-+ if ( themeQDir[y] != "." && themeQDir[y] != ".." && themeQDir[y] != "~custom" )
- {
- // Add ourselves to the list, using our directory name FIXME: use the first emoticon of the theme.
- QPixmap previewPixmap = QPixmap(locate("emoticons", themeQDir[y]+"/smile.png"));
-diff -ur kopete-0.12.1.orig/kopete/libkopete/private/kopeteemoticons.cpp kopete-0.12.1/kopete/libkopete/private/kopeteemoticons.cpp
---- kopete-0.12.1.orig/kopete/libkopete/private/kopeteemoticons.cpp 2006-07-13 02:55:52.000000000 +0200
-+++ kopete-0.12.1/kopete/libkopete/private/kopeteemoticons.cpp 2006-07-15 21:17:45.000000000 +0200
-@@ -345,8 +345,19 @@
- }
- }
-
-+void Emoticons::reload()
-+{
-+ initEmoticons( QString::null );
-+}
-+
- void Emoticons::initEmoticons( const QString &theme )
- {
-+ if(theme.compare( QString::fromLatin1("~custom") ) )
-+ {
-+ d->emoticonAndPicList.clear();
-+ d->emoticonMap.clear();
-+ initEmoticons( QString::fromLatin1("~custom") );
-+ }
- if(theme.isNull())
- {
- if ( d->theme == KopetePrefs::prefs()->iconTheme() )
-@@ -360,8 +371,6 @@
- }
-
- // kdDebug(14010) << k_funcinfo << "Called" << endl;
-- d->emoticonAndPicList.clear();
-- d->emoticonMap.clear();
-
- QString filename= KGlobal::dirs()->findResource( "emoticons", d->theme + QString::fromLatin1( "/emoticons.xml" ) );
- if(!filename.isEmpty())
-diff -ur kopete-0.12.1.orig/kopete/libkopete/private/kopeteemoticons.h kopete-0.12.1/kopete/libkopete/private/kopeteemoticons.h
---- kopete-0.12.1.orig/kopete/libkopete/private/kopeteemoticons.h 2006-07-13 02:55:52.000000000 +0200
-+++ kopete-0.12.1/kopete/libkopete/private/kopeteemoticons.h 2006-07-15 21:17:45.000000000 +0200
-@@ -162,6 +162,13 @@
- struct EmoticonNode;
- class Private;
- Private *d;
-+public slots:
-+ /**
-+ * Reload emoticons
-+ * Use this when changing current theme, for instance.
-+ */
-+ void reload();
-+
- private slots:
-
- /**
-
diff --git a/kde-base/kopete/files/kdenetwork-3.5.5-linux-headers-2.6.18.patch b/kde-base/kopete/files/kdenetwork-3.5.5-linux-headers-2.6.18.patch
deleted file mode 100644
index 30f2ee727ee3..000000000000
--- a/kde-base/kopete/files/kdenetwork-3.5.5-linux-headers-2.6.18.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- kopete/libkopete/avdevice/videodevice.h.orig 2006-10-17 14:34:13.000000000 +0200
-+++ kopete/libkopete/avdevice/videodevice.h 2006-10-17 14:37:00.000000000 +0200
-@@ -35,8 +35,8 @@
-
- #if defined(__linux__) && defined(ENABLE_AV)
-
--#include <asm/types.h>
- #undef __STRICT_ANSI__
-+#include <linux/types.h>
- #ifndef __u64 //required by videodev.h
- #define __u64 unsigned long long
- #endif // __u64
---- kopete/libkopete/avdevice/videoinput.h.orig 2006-10-17 14:38:43.000000000 +0200
-+++ kopete/libkopete/avdevice/videoinput.h 2006-10-17 14:39:50.000000000 +0200
-@@ -21,8 +21,8 @@
- #define KOPETE_AVVIDEOINPUT_H
-
- #ifdef __linux__
--#include <asm/types.h>
- #undef __STRICT_ANSI__
-+#include <linux/types.h>
- #endif // __linux__
- #ifndef __u64 //required by videodev.h
- #define __u64 unsigned long long
diff --git a/kde-base/kopete/files/kopete-0.12_alpha1-xscreensaver.patch b/kde-base/kopete/files/kopete-0.12_alpha1-xscreensaver.patch
deleted file mode 100644
index 2052d30cb450..000000000000
--- a/kde-base/kopete/files/kopete-0.12_alpha1-xscreensaver.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: kopete-0.12-alpha1/kopete/libkopete/configure.in.in
-===================================================================
---- kopete-0.12-alpha1.orig/kopete/libkopete/configure.in.in
-+++ kopete-0.12-alpha1/kopete/libkopete/configure.in.in
-@@ -4,7 +4,11 @@ LDFLAGS="$X_LDFLAGS"
-
- LIB_XSS=
-
--KDE_CHECK_HEADER(X11/extensions/scrnsaver.h,
-+AC_ARG_WITH([xscreensaver],
-+ AC_HELP_STRING([--without-xscreensaver], [Disable XScreenSaver support (default: check)]) )
-+
-+if test "x$with_xscreensaver" != "xno"; then
-+ KDE_CHECK_HEADER(X11/extensions/scrnsaver.h,
- [
- AC_CHECK_LIB(Xext,XScreenSaverQueryInfo,
- [
-@@ -27,6 +31,7 @@ KDE_CHECK_HEADER(X11/extensions/scrnsave
- [
- #include <X11/Xlib.h>
- ] )
-+fi
-
- AC_SUBST(LIB_XSS)
- LDFLAGS="$xss_save_ldflags"
diff --git a/kde-base/kopete/files/kopete-3.5-rolling_icon.patch b/kde-base/kopete/files/kopete-3.5-rolling_icon.patch
deleted file mode 100644
index 072425e28a58..000000000000
--- a/kde-base/kopete/files/kopete-3.5-rolling_icon.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- kopete/kopete/chatwindow/kopetechatwindow.cpp 2007-11-12 04:11:29.000000000 +0100
-+++ kopete/kopete/chatwindow/kopetechatwindow.cpp 2007-11-12 04:14:24.000000000 +0100
-@@ -442,7 +442,11 @@
- void KopeteChatWindow::slotStopAnimation( ChatView* view )
- {
- if( view == m_activeView )
-+ {
- anim->setPixmap( normalIcon );
-+ if( !animIcon.isNull() )
-+ animIcon.pause();
-+ }
- }
-
- void KopeteChatWindow::slotUpdateSendEnabled()
diff --git a/kde-base/kopete/files/kopete-3.5.10-gcc43.patch b/kde-base/kopete/files/kopete-3.5.10-gcc43.patch
deleted file mode 100644
index 814adf66863c..000000000000
--- a/kde-base/kopete/files/kopete-3.5.10-gcc43.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/asynctcpsocket.cc kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/asynctcpsocket.cc
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/asynctcpsocket.cc 2006-10-01 11:26:45.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/asynctcpsocket.cc 2008-09-29 20:52:46.000000000 -0600
-@@ -32,6 +32,7 @@
- #include "talk/base/byteorder.h"
- #include "talk/base/common.h"
- #include "talk/base/logging.h"
-+#include <cstring>
-
- #if defined(_MSC_VER) && _MSC_VER < 1300
- namespace std {
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/bytebuffer.cc kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/bytebuffer.cc
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/bytebuffer.cc 2006-10-01 11:26:45.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/bytebuffer.cc 2008-09-29 20:52:46.000000000 -0600
-@@ -30,6 +30,7 @@
- #include "talk/base/byteorder.h"
- #include <algorithm>
- #include <cassert>
-+#include <cstring>
-
- #if defined(_MSC_VER) && _MSC_VER < 1300
- namespace std {
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/host.cc kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/host.cc
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/host.cc 2006-10-01 11:26:45.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/host.cc 2008-09-29 20:52:46.000000000 -0600
-@@ -29,7 +29,8 @@
- #include "talk/base/logging.h"
- #include "talk/base/network.h"
- #include "talk/base/socket.h"
--#include <string>
-+#include <cstring>
-+#include <cstdlib>
- #include <iostream>
- #include <cassert>
- #include <errno.h>
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/messagequeue.h kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/messagequeue.h
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/messagequeue.h 2006-10-01 11:26:45.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/messagequeue.h 2008-09-29 20:52:46.000000000 -0600
-@@ -32,6 +32,7 @@
- #include "talk/base/criticalsection.h"
- #include "talk/base/socketserver.h"
- #include "talk/base/jtime.h"
-+#include <cstring>
- #include <vector>
- #include <queue>
- #include <algorithm>
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/physicalsocketserver.cc kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/physicalsocketserver.cc
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/physicalsocketserver.cc 2006-10-01 11:26:45.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/physicalsocketserver.cc 2008-09-29 20:52:46.000000000 -0600
-@@ -30,11 +30,13 @@
- #endif
-
- #include <cassert>
-+#include <algorithm>
-
- #ifdef POSIX
- extern "C" {
- #include <errno.h>
- #include <fcntl.h>
-+#include <string.h>
- #include <sys/time.h>
- #include <unistd.h>
- }
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/socketadapters.cc kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/socketadapters.cc
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/base/socketadapters.cc 2006-10-01 11:26:45.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/base/socketadapters.cc 2008-09-29 20:52:46.000000000 -0600
-@@ -42,6 +42,7 @@
- #endif
-
- #include <cassert>
-+#include <cstring>
-
- #include "talk/base/base64.h"
- #include "talk/base/basicdefs.h"
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stun.cc kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stun.cc
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stun.cc 2006-10-01 11:26:44.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stun.cc 2008-09-29 20:52:46.000000000 -0600
-@@ -29,6 +29,7 @@
- #include "talk/p2p/base/stun.h"
- #include <iostream>
- #include <cassert>
-+#include <cstring>
-
- #if defined(_MSC_VER) && _MSC_VER < 1300
- namespace std {
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stunserver.cc kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stunserver.cc
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stunserver.cc 2006-10-01 11:26:44.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/stunserver.cc 2008-09-29 20:52:46.000000000 -0600
-@@ -28,6 +28,7 @@
- #include "talk/base/bytebuffer.h"
- #include "talk/p2p/base/stunserver.h"
- #include <iostream>
-+#include <cstring>
-
- #ifdef POSIX
- extern "C" {
-diff -Naur kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/xmpp/xmpppassword.h kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/xmpp/xmpppassword.h
---- kopete-3.5.10-orig/kopete/protocols/jabber/jingle/libjingle/talk/xmpp/xmpppassword.h 2006-10-01 11:26:45.000000000 -0600
-+++ kopete-3.5.10/kopete/protocols/jabber/jingle/libjingle/talk/xmpp/xmpppassword.h 2008-09-29 20:52:46.000000000 -0600
-@@ -31,6 +31,8 @@
- #include "talk/base/linked_ptr.h"
- #include "talk/base/scoped_ptr.h"
-
-+#include <cstring>
-+
- namespace buzz {
-
- class XmppPasswordImpl {
diff --git a/kde-base/kopete/files/kopete-3.5.10-glibc210.patch b/kde-base/kopete/files/kopete-3.5.10-glibc210.patch
deleted file mode 100644
index 6caa8f17ca86..000000000000
--- a/kde-base/kopete/files/kopete-3.5.10-glibc210.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- kopete-3.5.10-r4-orig/work/kopete-3.5.10/kopete/protocols/oscar/liboscar/rtf.cc 2005-09-10 15:20:23.000000000 +0700
-+++ kopete-3.5.10-r4/work/kopete-3.5.10/kopete/protocols/oscar/liboscar/rtf.cc 2009-06-03 04:40:25.000000000 +0700
-@@ -2131,7 +2131,7 @@
-
- FontDef& def = p->fonts[m_nFont-1];
-
-- char *pp = strchr(str, ';');
-+ const char *pp = strchr(str, ';');
- unsigned size;
- if (pp != NULL)
- size = (pp - str);
---- kopete-3.5.10-r4-orig/work/kopete-3.5.10/kopete/protocols/oscar/liboscar/rtf.ll 2005-09-10 15:20:23.000000000 +0700
-+++ kopete-3.5.10-r4/work/kopete-3.5.10/kopete/protocols/oscar/liboscar/rtf.ll 2009-06-03 04:40:35.000000000 +0700
-@@ -568,7 +568,7 @@
-
- FontDef& def = p->fonts[m_nFont-1];
-
-- char *pp = strchr(str, ';');
-+ const char *pp = strchr(str, ';');
- unsigned size;
- if (pp != NULL)
- size = (pp - str);
diff --git a/kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch b/kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch
deleted file mode 100644
index 37a4afd4bdbb..000000000000
--- a/kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urNpa kopete-3.5.9.orig/kopete/protocols/oscar/liboscar/connection.cpp kopete-3.5.9/kopete/protocols/oscar/liboscar/connection.cpp
---- kopete-3.5.9.orig/kopete/protocols/oscar/liboscar/connection.cpp 2009-02-04 17:34:44.000000000 +0300
-+++ kopete-3.5.9/kopete/protocols/oscar/liboscar/connection.cpp 2009-02-04 17:40:47.000000000 +0300
-@@ -31,6 +31,10 @@
-
- #include "oscartypeclasses.h"
-
-+const Oscar::WORD StarSequences[] = {
-+5695, 23595, 23620, 23049, 0x2886, 0x2493, 23620, 23049, 2853, 17372, 1255, 1796, 1657, 13606, 1930, 23918, 31234, 30120, 0x1BEA, 0x5342, 0x30CC, 0x2294, 0x5697, 0x25FA, 0x3C26, 0x3303, 0x078A, 0x0FC5, 0x25D6, 0x26EE,0x7570, 0x7F33, 0x4E94, 0x07C9, 0x7339, 0x42A8
-+//0x39B1, 0x1F07
-+};
-
- class ConnectionPrivate
- {
-@@ -208,7 +212,8 @@ void Connection::forcedSend( Transfer* r
- void Connection::initSequence()
- {
- d->snacSequence = ( KApplication::random() & 0xFFFF );
-- d->flapSequence = ( KApplication::random() & 0xFFFF );
-+ int startSequencesIndex = KApplication::random() % ((sizeof StarSequences) / (sizeof StarSequences[0]));
-+ d->flapSequence = StarSequences[startSequencesIndex] - 1;
- }
-
- void Connection::distribute( Transfer * transfer ) const
diff --git a/kde-base/kopete/files/kopete-3.5.10-jabber-protocol-gtalknickfix.patch b/kde-base/kopete/files/kopete-3.5.10-jabber-protocol-gtalknickfix.patch
deleted file mode 100644
index 01ad284d9839..000000000000
--- a/kde-base/kopete/files/kopete-3.5.10-jabber-protocol-gtalknickfix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- kopete/protocols/jabber/jabberbasecontact.cpp.orig 2009-03-15 18:42:43.000000000 +0500
-+++ kopete/protocols/jabber/jabberbasecontact.cpp 2009-03-15 18:44:13.000000000 +0500
-@@ -428,6 +428,10 @@
- {
- setProperty ( protocol()->propNickName, vCard.nickName () );
- }
-+ else if ( !vCard.fullName().isEmpty () ) // google talk contacts for example do not have a nickname; better show fullname instead of jabber id
-+ {
-+ setProperty ( protocol()->propNickName, vCard.fullName () );
-+ }
- else
- {
- removeProperty ( protocol()->propNickName );
diff --git a/kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch b/kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch
deleted file mode 100644
index 84ef79bb71e9..000000000000
--- a/kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-------------------------------------------------------------------------
-r638 | wojtekka | 2008-10-23 23:50:29 +0200 (Thu, 23 Oct 2008) | 2 lines
-
-Poprawka błędu analizowania pakietów GG_NOTIFY_REPLY* znalezionego przez Jakuba Zawadzkiego. Odpowiednio spreparowany pakiet wysłany przez serwer może spowodować naruszenie ochrony pamięci.
-
-------------------------------------------------------------------------
-Index: kopete-3.5.9/kopete/protocols/gadu/libgadu/events.c
-===================================================================
---- kopete-3.5.9.orig/kopete/protocols/gadu/libgadu/events.c
-+++ kopete-3.5.9/kopete/protocols/gadu/libgadu/events.c
-@@ -598,7 +598,7 @@ static int gg_watch_fd_connected(struct
- if (GG_S_D(n->status)) {
- unsigned char descr_len = *((char*) n + sizeof(struct gg_notify_reply60));
-
-- if (descr_len < length) {
-+ if (sizeof(struct gg_notify_reply60) + descr_len <= length) {
- if (!(e->event.notify60[i].descr = malloc(descr_len + 1))) {
- gg_debug(GG_DEBUG_MISC, "// gg_watch_fd_connected() not enough memory for notify data\n");
- goto fail;
diff --git a/kde-base/kopete/files/kopete-3.5.5-icqfix.patch b/kde-base/kopete/files/kopete-3.5.5-icqfix.patch
deleted file mode 100644
index 4aa3f2759c14..000000000000
--- a/kde-base/kopete/files/kopete-3.5.5-icqfix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: kdenetwork-3.5.5/kopete/protocols/oscar/liboscar/client.cpp
-===================================================================
---- kdenetwork-3.5.5.orig/kopete/protocols/oscar/liboscar/client.cpp
-+++ kdenetwork-3.5.5/kopete/protocols/oscar/liboscar/client.cpp
-@@ -340,6 +340,7 @@ void Client::lt_loginFinished()
- //we've finished logging in. start the services setup
- kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
- initializeStaticTasks();
-+ d->ownStatusTask->go();
- ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
- connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
- ssTask->go( true ); //fire and forget