summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-15 17:26:17 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-15 17:26:17 +0000
commita1791ffdeef04d26d269c5721abc2f2df53681a3 (patch)
treedea83b6a54feb970d5983a5fc1b578418173ec11 /kde-base/korundum/korundum-4.7.0.ebuild
parentamd64 stable wrt #386957 (diff)
downloadgentoo-2-a1791ffdeef04d26d269c5721abc2f2df53681a3.tar.gz
gentoo-2-a1791ffdeef04d26d269c5721abc2f2df53681a3.tar.bz2
gentoo-2-a1791ffdeef04d26d269c5721abc2f2df53681a3.zip
Drop KDE 4.7.0
(Portage version: 2.1.10.27/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/korundum/korundum-4.7.0.ebuild')
-rw-r--r--kde-base/korundum/korundum-4.7.0.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/kde-base/korundum/korundum-4.7.0.ebuild b/kde-base/korundum/korundum-4.7.0.ebuild
deleted file mode 100644
index 42978f0f4c42..000000000000
--- a/kde-base/korundum/korundum-4.7.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.7.0.ebuild,v 1.1 2011/07/27 14:04:26 alexxy Exp $
-
-EAPI=4
-
-OPENGL_REQUIRED="always"
-KDE_SCM="git"
-
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="KDE Ruby bindings"
-KEYWORDS="~amd64 ~x86"
-IUSE="akonadi debug kate okular semantic-desktop"
-
-DEPEND="
- $(add_kdebase_dep qtruby)
- $(add_kdebase_dep smokekde 'akonadi?,kate?,okular?,semantic-desktop=')
- $(add_kdebase_dep smokeqt)
-"
-RDEPEND="${DEPEND}
- !dev-ruby/qt4-qtruby
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_with akonadi)
- $(cmake-utils_use_with akonadi KdepimLibs)
- $(cmake-utils_use_disable kate)
- $(cmake-utils_use_with okular)
- $(cmake-utils_use_with semantic-desktop Nepomuk)
- $(cmake-utils_use_with semantic-desktop Soprano)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}