summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 21:08:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 21:08:58 +0000
commitd3b8ce2838c81656c782f6fcecaacb4aa713c0d7 (patch)
treeb720be94db386fe335df9aac0f3fe8a830a3d41c /kde-base/kpilot
parentBump to 3.5.6 (prerelease). (diff)
downloadgentoo-2-d3b8ce2838c81656c782f6fcecaacb4aa713c0d7.tar.gz
gentoo-2-d3b8ce2838c81656c782f6fcecaacb4aa713c0d7.tar.bz2
gentoo-2-d3b8ce2838c81656c782f6fcecaacb4aa713c0d7.zip
Bump to 3.5.6 (prerelease).
(Portage version: 2.1.2)
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog9
-rw-r--r--kde-base/kpilot/files/digest-kpilot-3.5.63
-rw-r--r--kde-base/kpilot/kpilot-3.5.6.ebuild39
3 files changed, 49 insertions, 2 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index 3d3079891fda..42967c11e88b 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kpilot
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.52 2006/12/11 14:20:32 kloeri Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.53 2007/01/16 21:08:57 flameeyes Exp $
+
+*kpilot-3.5.6 (16 Jan 2007)
+
+ 16 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> +kpilot-3.5.6.ebuild:
+ Bump to 3.5.6 (prerelease).
11 Dec 2006; <kloeri@gentoo.org> ChangeLog:
Stable on ia64.
diff --git a/kde-base/kpilot/files/digest-kpilot-3.5.6 b/kde-base/kpilot/files/digest-kpilot-3.5.6
new file mode 100644
index 000000000000..48727dabc040
--- /dev/null
+++ b/kde-base/kpilot/files/digest-kpilot-3.5.6
@@ -0,0 +1,3 @@
+MD5 06744c36252414c809d6df46058f1bfd kdepim-3.5.6.tar.bz2 13645180
+RMD160 c68a01d9ce29d3ad41e18a79f39a961d2ef2383a kdepim-3.5.6.tar.bz2 13645180
+SHA256 018027c75944ef9ea471c1422269832fc890f004c2684144859c301c6d7d5bf6 kdepim-3.5.6.tar.bz2 13645180
diff --git a/kde-base/kpilot/kpilot-3.5.6.ebuild b/kde-base/kpilot/kpilot-3.5.6.ebuild
new file mode 100644
index 000000000000..17913109a2a5
--- /dev/null
+++ b/kde-base/kpilot/kpilot-3.5.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.5.6.ebuild,v 1.1 2007/01/16 21:08:57 flameeyes Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KPilot - HotSync software for KDE."
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="app-pda/pilot-link
+ dev-libs/libmal
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/kontact)"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+ libkcal libkcal
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/
+ libkdepim libkdepim/
+ kontact/interfaces/"
+KMEXTRA="
+ kfile-plugins/palm-databases
+ kontact/plugins/kpilot/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_compile() {
+ # needed to detect pi-notepad.h, used by the kpilot notepad conduit.
+ myconf="${myconf} --with-extra-includes=/usr/include/libpisock"
+
+ kde-meta_src_compile
+}