summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-30 21:35:23 +0000
committerDror Levin <spatz@gentoo.org>2010-03-30 21:35:23 +0000
commit4d0a8238661b95548f4cb5dfe62b1e8c73504b44 (patch)
tree43db4603efff8431f2193bfe29f2d50aa97ac684 /kde-base/ksplash
parentVersion bump KDE 4.4.2 (diff)
downloadgentoo-2-4d0a8238661b95548f4cb5dfe62b1e8c73504b44.tar.gz
gentoo-2-4d0a8238661b95548f4cb5dfe62b1e8c73504b44.tar.bz2
gentoo-2-4d0a8238661b95548f4cb5dfe62b1e8c73504b44.zip
Version bump KDE 4.4.2
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.4.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 8edb81ddba27..0c3518daebfe 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.58 2010/03/11 18:36:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.59 2010/03/30 21:35:23 spatz Exp $
+
+*ksplash-4.4.2 (30 Mar 2010)
+
+ 30 Mar 2010; Dror Levin <spatz@gentoo.org> +ksplash-4.4.2.ebuild:
+ Version bump
11 Mar 2010; Brent Baude <ranger@gentoo.org> ksplash-4.3.5.ebuild:
Marking ksplash-4.3.5 ppc stable for bug 300393
diff --git a/kde-base/ksplash/ksplash-4.4.2.ebuild b/kde-base/ksplash/ksplash-4.4.2.ebuild
new file mode 100644
index 000000000000..cc4a0889d386
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.4.2.ebuild,v 1.1 2010/03/30 21:35:23 spatz Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}