summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 21:23:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 21:23:25 +0000
commit11dbc94fe182497235ca2d8934fc5f106f2ae450 (patch)
tree96a31e0152b52bb1a3fac9f8860fb4f40fa830bc /kde-base/ksplashml/ksplashml-3.5.6.ebuild
parentBump to 3.5.6 (prerelease). (diff)
downloadgentoo-2-11dbc94fe182497235ca2d8934fc5f106f2ae450.tar.gz
gentoo-2-11dbc94fe182497235ca2d8934fc5f106f2ae450.tar.bz2
gentoo-2-11dbc94fe182497235ca2d8934fc5f106f2ae450.zip
Bump to 3.5.6 (prerelease).
(Portage version: 2.1.2)
Diffstat (limited to 'kde-base/ksplashml/ksplashml-3.5.6.ebuild')
-rw-r--r--kde-base/ksplashml/ksplashml-3.5.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/ksplashml/ksplashml-3.5.6.ebuild b/kde-base/ksplashml/ksplashml-3.5.6.ebuild
new file mode 100644
index 000000000000..f3b4aed4322f
--- /dev/null
+++ b/kde-base/ksplashml/ksplashml-3.5.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ksplashml-3.5.6.ebuild,v 1.1 2007/01/16 21:23:25 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xinerama"
+
+RDEPEND="xinerama? ( || ( x11-libs/libXinerama <virtual/x11-7 ) )"
+
+DEPEND="${RDEPEND}
+ xinerama? ( || ( x11-proto/xineramaproto <virtual/x11-7 ) )"
+
+src_compile() {
+ myconf="${myconf} $(use_with xinerama)"
+
+ kde-meta_src_compile
+}