summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-23 00:55:18 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-23 00:55:18 +0000
commitb0dd6b952f99346f5ebbca3975ca5393c51e3a1f (patch)
tree6f8ad69027738e05cba6609e2984ccdf715f4f56 /kde-base/kstars
parentRemoval for EOL and security, bug #287615, moved to java junkyard. (diff)
downloadgentoo-2-b0dd6b952f99346f5ebbca3975ca5393c51e3a1f.tar.gz
gentoo-2-b0dd6b952f99346f5ebbca3975ca5393c51e3a1f.tar.bz2
gentoo-2-b0dd6b952f99346f5ebbca3975ca5393c51e3a1f.zip
Pull in changes from overlay and add patch prefix support (Solaris)
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog6
-rw-r--r--kde-base/kstars/files/kstars-4.3.2-solaris.patch26
-rw-r--r--kde-base/kstars/kstars-4.3.4.ebuild11
3 files changed, 39 insertions, 4 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index c9e224d6222d..2d6dc96f3fc5 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.149 2009/12/10 22:34:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.150 2009/12/23 00:55:18 abcd Exp $
+
+ 23 Dec 2009; Jonathan Callen <abcd@gentoo.org>
+ +files/kstars-4.3.2-solaris.patch, kstars-4.3.4.ebuild:
+ Pull in changes from overlay and add patch prefix support (Solaris)
10 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> -kstars-4.3.1.ebuild:
Drop KDE SC-4.3.1.
diff --git a/kde-base/kstars/files/kstars-4.3.2-solaris.patch b/kde-base/kstars/files/kstars-4.3.2-solaris.patch
new file mode 100644
index 000000000000..4c5cfefdf904
--- /dev/null
+++ b/kde-base/kstars/files/kstars-4.3.2-solaris.patch
@@ -0,0 +1,26 @@
+Desc: Fix compilation on Solaris with some defines.
+Author: Heiko Przybyl <zuxez@cs.tu-berlin.de>
+--- kstars-4.3.2/kstars/kstars/htmesh/SpatialGeneral.h.orig 2009-10-16 17:32:00.241610236 +0200
++++ kstars-4.3.2/kstars/kstars/htmesh/SpatialGeneral.h 2009-10-16 17:32:36.949967839 +0200
+@@ -80,7 +80,7 @@ typedef unsigned long long uint64;
+
+ // emulate the standard bool type where not supported by compiler
+
+-# if !defined(SXGENERAL_H) && !defined(__sgi) && !defined(__linux__) && !defined(_WIN32) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
++# if !defined(SXGENERAL_H) && !defined(__sgi) && !defined(__linux__) && !defined(_WIN32) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__sun)
+ # ifdef __unix__
+ /*
+ * The following ifndef must ALWAYS be present since C++ may use
+--- kstars-4.3.2/kstars/kstars/skycomponents/starcomponent.cpp.orig 2009-10-16 17:43:41.053792704 +0200
++++ kstars-4.3.2/kstars/kstars/skycomponents/starcomponent.cpp 2009-10-16 17:44:40.365860457 +0200
+@@ -44,6 +44,10 @@
+ #include <sys/endian.h>
+ #define bswap_16(x) bswap16(x)
+ #define bswap_32(x) bswap32(x)
++#elif defined(__sun)
++#include <sys/byteorder.h>
++#define bswap_16(x) BSWAP_16(x)
++#define bswap_32(x) BSWAP_32(x)
+ #else
+ #include <byteswap.h>
+ #endif
diff --git a/kde-base/kstars/kstars-4.3.4.ebuild b/kde-base/kstars/kstars-4.3.4.ebuild
index f8d6335602bd..709c5a5a7499 100644
--- a/kde-base/kstars/kstars-4.3.4.ebuild
+++ b/kde-base/kstars/kstars-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.3.4.ebuild,v 1.1 2009/12/01 11:06:10 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.3.4.ebuild,v 1.2 2009/12/23 00:55:18 abcd Exp $
EAPI="2"
KMNAME="kdeedu"
@@ -17,10 +17,15 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
src_configure() {
- mycmakeargs="${mycmakeargs}
+ mycmakeargs=(
$(cmake-utils_use_with fits CFitsio)
- $(cmake-utils_use_with indi INDI)"
+ $(cmake-utils_use_with indi)
+ )
kde4-meta_src_configure
}