summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-29 18:53:12 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-29 18:53:12 +0000
commit195d58ebf3770cb8912618973dd03b62591c38b2 (patch)
tree4b4c0d4d4faa042e51cd583d0e4ff0f64ccb0613 /kde-base/kwin
parentVersion bump KDE SC 4.12.5 (diff)
downloadgentoo-2-195d58ebf3770cb8912618973dd03b62591c38b2.tar.gz
gentoo-2-195d58ebf3770cb8912618973dd03b62591c38b2.tar.bz2
gentoo-2-195d58ebf3770cb8912618973dd03b62591c38b2.zip
Version bump KDE Workspace 4.11.9
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.11.9.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index f2f270996b57..1640caebb881 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.378 2014/04/01 18:24:13 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.379 2014/04/29 18:53:08 johu Exp $
+
+*kwin-4.11.9 (29 Apr 2014)
+
+ 29 Apr 2014; Johannes Huber <johu@gentoo.org> +kwin-4.11.9.ebuild:
+ Version bump KDE Workspace 4.11.9
*kwin-4.11.8 (01 Apr 2014)
diff --git a/kde-base/kwin/kwin-4.11.9.ebuild b/kde-base/kwin/kwin-4.11.9.ebuild
new file mode 100644
index 000000000000..7292e3a47d55
--- /dev/null
+++ b/kde-base/kwin/kwin-4.11.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.11.9.ebuild,v 1.1 2014/04/29 18:53:08 johu Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="always"
+
+#VIRTUALX_REQUIRED=test
+RESTRICT=test
+# test 8: kwin-TestVirtualDesktops hangs even with virtualx
+
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE window manager"
+HOMEPAGE+=" http://userbase.kde.org/KWin"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gles opengl wayland"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs opengl)
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep liboxygenstyle)
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ x11-libs/libXxf86vm
+ opengl? ( >=media-libs/mesa-7.10 )
+ gles? ( >=media-libs/mesa-7.12[egl(+),gles2] )
+ wayland? ( >=media-libs/mesa-9.0[egl(+),wayland] )
+"
+DEPEND="${COMMONDEPEND}
+ x11-libs/xcb-util-renderutil
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/scripts
+"
+
+KMEXTRACTONLY="
+ ksmserver/
+ libs/kephal/
+ libs/oxygen/
+"
+
+# you need one of these
+REQUIRED_USE="!opengl? ( gles ) !gles? ( opengl ) wayland? ( gles )"
+
+src_configure() {
+ # FIXME Remove when activity API moved away from libkworkspace
+ append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
+
+ mycmakeargs=(
+ $(cmake-utils_use_with gles OpenGLES)
+ $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with wayland Wayland)
+ -DWITH_X11_Xcomposite=ON
+ )
+
+ kde4-meta_src_configure
+}